Bug 18938 - nfs file locking broken on Athlon cpu's
nfs file locking broken on Athlon cpu's
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Pete Zaitcev
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-12 04:56 EDT by Gerald Teschl
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-19 13:33:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Teschl 2000-10-12 04:56:01 EDT
NFS locking does not work on Athlon K7 cpu's.
I have several Worksations running RH7.0 (plus all updates) and on all
machines with
Athlon K7 cpu's NFS locking is broken: E.g. using elm "Cannot flock folder
"/var/spool/mail/gerald"! [No locks available]". Pentium, Pentium II,
Pentium III
systems with identical setup work fine. I testet this with both a server
running 6.2 and 7.0.
I also tried to use the i386 kernel.

Here is /proc/cpuinfo which don't work:
[gerald@ws11 gerald]$ cat /proc/cpuinfo
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 6
model           : 4
model name      : AMD Athlon(tm) Processor
stepping        : 2
cpu MHz         : 700.051
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
sep_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr 6 mce cx8 sep mtrr pge 14 cmov
fcmov 17 psn 22 mmx 24 30 3dnow
bogomips        : 1395.92 

On some other AThlon cpu's there are no problems
[gerald@bounder gerald]$ cat /proc/cpuinfo
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 6
model           : 2
model name      : AMD Athlon(tm) Processor
stepping        : 2
cpu MHz         : 700.056
cache size      : 512 KB
fdiv_bug        : no
hlt_bug         : no
sep_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr 6 mce cx8 sep mtrr pge 14 cmov
fcmov 17 22 mmx 24 30 3dnow
bogomips        :
1395.92
Comment 1 Gerald Teschl 2000-12-19 13:33:54 EST
The problem is caused by the host's IP not showing up in /etc/hosts.

Note You need to log in before you can comment on or make changes to this bug.