Bug 189409 - iostat shows zero blocks read/written on HP SmartArray 6i
iostat shows zero blocks read/written on HP SmartArray 6i
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-19 15:49 EDT by Aleksander Adamowski
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.20-1.2316.fc5xen0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-04 10:14:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksander Adamowski 2006-04-19 15:49:45 EDT
Description of problem:

This is similar to the old bug 69525. 

On a HP DL385 Opteron server (x86_64), I have a SmartArray 6i controller:

$ hpacucli controller slot=0 show
Controller Smart Array 6i in Slot 0
   Bus Interface: pci
   slot: 0
   Cache serialnumber: P75B20C9SRP6G1
   RAID ADG status: False
   Controller Status: OK
   Chassis Slot: 1
   Hardware Revision: Rev B
   Firmware Version: 2.36
   Rebuild Priority: Low
   Expand Priority: Low
   Surface Scan Delay: 15 sec
   Cache Board Present: True
   Cache Status: OK
   Accelerator Ratio: 25/75 (read/write)
   Read Cache Size: 32 MB
   Write Cache Size: 96 MB
   Total Cache Size: 128 MB
   Battery Backed Cache Size: 128 MB
   Non Battery Backed Cache Size: 0 MB
   Battery Pack Count: 1
   Battery Status: OK



The iostat utility always shows zero blocks read/written for this device:

Linux 2.6.15-1.1833_FC4smp (hostname.domain)    04/19/2006

avg-cpu:  %user   %nice    %sys %iowait   %idle
           1.89    3.85    1.42    1.21   91.63

Device:            tps   Blk_read/s   Blk_wrtn/s   Blk_read   Blk_wrtn
cciss/c0d0       33.59         0.00         0.00          0          0


What's interesting, vmstat shows the blocks in/blocks out correctly:

$ vmstat 
procs -----------memory---------- ---swap-- -----io---- --system-- ----cpu----
 r  b   swpd   free   buff  cache   si   so    bi    bo   in    cs us sy id wa
 0  0   5564  44084 277188 1183820    0    0    74    81    5     0  6  1 92  1


Version-Release number of selected component (if applicable):

sysstat-5.0.5-9.fc

How reproducible:


Steps to Reproduce:
1. run iostat
2. look at the values for blocks read/written (and blocks read/written per second)

  
Actual results:
The values for blocks read/written (and blocks read/written per second) are
always zero.
Comment 1 Ivana Varekova 2006-04-20 06:52:53 EDT
Please could you try to reproduce this bug with the latest devel version of
sysstat - sysstat-6.0.1-3.2.1.
Comment 2 Aleksander Adamowski 2006-08-24 05:25:36 EDT
I've installed the currently available development version - sysstat-7.0.0-1 -
and it shows zero results too:

$ iostat 
Linux 2.6.17-1.2142_FC4 (hostname)       08/24/2006

avg-cpu:  %user   %nice %system %iowait  %steal   %idle
          12.54    3.01    4.76    2.96    0.00   76.73

Device:            tps   Blk_read/s   Blk_wrtn/s   Blk_read   Blk_wrtn
cciss/c0d0       39.13         0.00         0.00          0          0

This is on Fedora Core 4.

Also, I've tested this on Fedora Core 5, where sysstat is at version 6.0.1-3.2.1.

Same results:

# iostat 
Linux 2.6.17-1.2157_FC5xen0 (hostname2)        08/24/2006

avg-cpu:  %user   %nice %system %iowait   %idle
          25.02    0.00    0.03    0.72   74.23

Device:            tps   Blk_read/s   Blk_wrtn/s   Blk_read   Blk_wrtn
cciss/c0d0       29.29         0.00         0.00          0          0


Both machines have x86_64 architecture (HP ProLiant 385 servers).
Comment 3 Ivana Varekova 2006-10-25 08:52:14 EDT
I can't reproduce this problem, coud you please try to reproduce this problem
with the test package
(http://people.redhat.com/varekova/sysstat-7.0.0-2.test.src.rpm or
http://people.redhat.com/varekova/sysstat-7.0.0-2.test.x86_64.rpm) - there are
add auxiliary outputs which should help to detect the problem. 
Comment 4 Aleksander Adamowski 2006-11-03 03:56:30 EST
Here are the results from the modified sysstat:

# iostat 
Linux 2.6.17-1.2157_FC5xen0 (hostname)        11/03/2006

avg-cpu:  %user   %nice %system %iowait  %steal   %idle
           0.12    0.00    0.06    0.78    0.03   99.01

Device:            tps   Blk_read/s   Blk_wrtn/s   Blk_read   Blk_wrtn
cciss/c0d0       52.43         0.00         0.00          0          0
a0 - dk_drive               0    6351816
a1 - dk_drive_rblk          0    6372454
a2 - dk_drive_wblk          0 2863371480
a3 - itv   38979274 fctr          1 rd_sec          0 wr_sec          0
Comment 5 Ivana Varekova 2006-11-03 06:12:57 EST
Thank you.
Please could you run one more test version:
(http://people.redhat.com/varekova/sysstat-7.0.2-2.test2.src.rpm or
http://people.redhat.com/varekova/sysstat-7.0.2-2.test2.x86_64.rpm)
- there are more outputs.
Comment 6 Aleksander Adamowski 2006-11-08 04:29:29 EST
Here are the results with sysstat-7.0.2-2.test2:

# iostat 
Linux 2.6.17-1.2157_FC5xen0 (hostname)        11/08/2006

avg-cpu:  %user   %nice %system %iowait  %steal   %idle
           0.09    0.00    0.05    0.62    0.03   99.21

Device:            tps   Blk_read/s   Blk_wrtn/s   Blk_read   Blk_wrtn
cciss/c0d0       37.99         0.00         0.00          0          0
a0 -           0          0          0    5353993
a1 -           0          0
a2 -           0          0
a3 - itv   82379863 fctr          1 rd_sec          0 wr_sec          0
Comment 7 Ivana Varekova 2006-11-08 05:44:17 EST
Thank for your help, but there will be need one last test - could you please run
http://people.redhat.com/varekova/iostat.test and attach the output (it is for
x86_64), thaks.
Comment 8 Aleksander Adamowski 2006-11-09 13:28:17 EST
Not much success:

# ./iostat.test 
Floating point exception


Note that I'm on Fedora Core 5. I had to rebuild all the test SRPMS to get
binary ones that work.
Comment 9 Ivana Varekova 2006-11-13 09:28:48 EST
Thanks for your response.
The test srpm is on 
http://people.redhat.com/varekova/sysstat-7.0.2-2.test3.src.rpm.
Comment 10 Aleksander Adamowski 2006-11-23 06:26:10 EST
Done:

# iostat 
Linux 2.6.18-1.2200.fc5xen0 (hostname)        11/23/2006

avg-cpu:  %user   %nice %system %iowait  %steal   %idle
           0.05    0.00    0.03    0.61    0.03   99.27

Device:            tps   Blk_read/s   Blk_wrtn/s   Blk_read   Blk_wrtn
cciss/c0d0       29.08         0.00         0.00          0          0
a0 -                0        29461524               0         5102268
a1 -                0               0
a2 -                0               0
a3 - itv  118867750 fctr          1 rd_sec          0 wr_sec          0
Comment 11 Ivana Varekova 2006-12-01 05:09:04 EST
sysstat works right, there is a problem with the values which which are written
in /proc directory. 
Comment 12 Aleksander Adamowski 2007-09-07 13:17:28 EDT
FYI, here's the output on kernel 2.6.20-1.2316.fc5xen0:

Linux 2.6.20-1.2316.fc5xen0 (hostname)        09/07/2007

avg-cpu:  %user   %nice %system %iowait  %steal   %idle
           0.07    0.00    0.03    1.64    0.02   98.24

Device:            tps   Blk_read/s   Blk_wrtn/s   Blk_read   Blk_wrtn
cciss/c0d0       54.25      1252.95       430.85 4491065703 1544333552
a0 -                0       138831890               0        55622089
a1 -                0      4491065703
a2 -                0      1544333552
a3 - itv  358439069 fctr          1 rd_sec 4491065703 wr_sec 1544333552


Seems fixed with new kernel release.
Comment 13 Jay Fenlason 2007-10-04 10:14:12 EDT
Closing as per #12

Note You need to log in before you can comment on or make changes to this bug.