Bug 189418 - rpmbuild --rebuild gnome-python2-extras-2.14.0-1.src.rpm fails
rpmbuild --rebuild gnome-python2-extras-2.14.0-1.src.rpm fails
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-python2-extras (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-19 17:05 EDT by Mads Villadsen
Modified: 2008-08-02 19:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-19 16:27:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Villadsen 2006-04-19 17:05:45 EDT
Description of problem:
I am trying to rebuild gnome-python2-extras, but the build fails.

Version-Release number of selected component (if applicable):
gnome-python2-extras 2.14.0-1

How reproducible:
Always.

Steps to Reproduce:
1. rpmbuild --rebuild gnome-python2-extras-2.14.0-1.src.rpm
2. everything seems to compile just fine until it starts compiling egg-trayicon.
Then the following lines appear:

source='trayicon.c' object='trayicon_la-trayicon.lo' libtool=yes \
DEPDIR=.deps depmode=none /bin/sh ../../depcomp \
/bin/sh ../../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I.
-I../.. -I/usr/include/python2.4 -I/usr/include/pygtk-2.0
-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include    -DEGG_COMPILATION  
-I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0
-I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include   -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2
-fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386
-mtune=generic -fasynchronous-unwind-tables -fno-strict-aliasing -c -o
trayicon_la-trayicon.lo `test -f 'trayicon.c' || echo './'`trayicon.c
 gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I/usr/include/python2.4
-I/usr/include/pygtk-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
-DEGG_COMPILATION -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include
-I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0
-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables
-fno-strict-aliasing -c trayicon.c  -fPIC -DPIC -o .libs/trayicon_la-trayicon.o
/bin/sh ../../libtool --tag=CC --mode=link gcc  -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables
-fno-strict-aliasing   -o trayicon.la -rpath
/usr/lib/python2.4/site-packages/gtk-2.0/egg -module -avoid-version
-export-symbols-regex inittrayicon trayicon_la-trayiconmodule.lo
trayicon_la-eggtrayicon.lo trayicon_la-trayicon.lo -lgtk-x11-2.0 -lgdk-x11-2.0
-latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangocairo-1.0 -lpango-1.0 -lcairo
-lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0
generating symbol list for `trayicon.la'
nm  .libs/trayicon_la-trayiconmodule.o .libs/trayicon_la-eggtrayicon.o
.libs/trayicon_la-trayicon.o  |  | /bin/sed 's/.* //' | sort | uniq >
.libs/trayicon.exp
../../libtool: eval: line 4165: syntax error near unexpected token `|'
../../libtool: eval: line 4165: `nm  .libs/trayicon_la-trayiconmodule.o
.libs/trayicon_la-eggtrayicon.o .libs/trayicon_la-trayicon.o  |  | /bin/sed
's/.* //' | sort | uniq > .libs/trayicon.exp'
make[3]: *** [trayicon.la] Error 1
make[3]: Leaving directory
`/home/maxx/rpmbuild/BUILD/gnome-python-extras-2.14.0/egg/tray'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory
`/home/maxx/rpmbuild/BUILD/gnome-python-extras-2.14.0/egg'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/maxx/rpmbuild/BUILD/gnome-python-extras-2.14.0'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.83606 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.83606 (%build)



It seems to me that somehow there is a command missing between two pipes...
Comment 1 Mads Villadsen 2006-08-20 14:13:58 EDT
The problem still occurs with fc6t2 (fully updated 2006-08-19) with
gnome-python2-extras-2.14.1-6.

It also fails when compiling gimmie from cvs.
Comment 2 Matthew Barnes 2006-09-23 21:09:41 EDT
I just tried "rpmbuild --rebuild gnome-python2-extras-2.14.2-2.fc6.src.rpm" and
it built successfully for me.

Can you try it again with the latest Rawhide package?
Comment 3 Mads Villadsen 2006-10-19 16:27:00 EDT
Works for me now in rawhide

Note You need to log in before you can comment on or make changes to this bug.