Bug 189444 - Firefox Beagle Extension broke
Firefox Beagle Extension broke
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: beagle (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-19 20:31 EDT by teamwassily
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-14 17:43:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description teamwassily 2006-04-19 20:31:55 EDT
Description of problem:

After updating to Firefox 1.5.0.2 on FC5, the Beagle extension appears
to be broke.  Under any user account when I start Firefox 1.5.0.2 I get a dialog
box entitled 'Malformed File' that says:

'Firefox could not install this item because "install.rdf" (provided
by the item) is not well-formed or does not exist.  Please contact the
author about this problem.'

This is a one-time issue for all user accounts.  The consequence of
that dialog box is that the Beagle extension is no longer listed in
the Extensions list.  It's gone.

Version-Release number of selected component (if applicable):
Beagle 0.2.4 [updates-testing] and Firefox 1.5.0.2

How reproducible:
Always.  Each user account will remove the Beagle extension once Firefox is run.

Steps to Reproduce:
1.Run firefox 1.5.0.2
2.Dialog box will pop up
3.Beagle extension is gone
  
Actual results:
Beagle extension removed.

Expected results:
Beagle extension remains, perhaps updates to a new version to be compatibile
with 1.5.0.2 or something.

Additional info:

If the problem was with the Beagle extension needing to be updated to work with
Firefox 1.5.0.2, then wouldn't there be a check for an update?  Instead I get a
message about a problem with an install.rdf.  Odd stuff.

I use the [updates-testing] channel for FC5 and am fully up-to-date.
Comment 1 Evan Clarke 2006-04-20 07:35:59 EDT
Additionally I find that after visiting a https site (that beagle extension
automatically disables for), the beagle extension does not automatically
re-enable.  Also, the indexing is disabled for all tabs, not just the https tab.
Comment 2 Sean Carlos 2006-04-20 14:03:51 EDT
This is a known beagle bug, fixed in 0.2.5:

Subject: ANNOUNCE: Beagle 0.2.5
Date: Thu, 20 Apr 2006 13:10:07 -0400
From: Joe Shaw <joeshaw novell com>
To: dashboard-hackers gnome org
CC: gnome-announce-list gnome org

Hi,

I'm pleased to announce the release of Beagle 0.2.5.

Version 0.2.4 shipped with a broken HTML filter, which meant that web
pages that were indexed because of the Firefox extension couldn't be
searched.  This release fixes that.  Also fixed is a compilation error
triggered by the more strict Mono 1.1.14 C# compiler.  This version is
also the first to correctly handle a broken X connection, meaning
Beagle will now shut down cleanly when you log out if you started it 
at login.
Comment 3 Christopher Aillon 2006-09-14 17:43:23 EDT
Please file beagle extension bugs against beagle.

Note You need to log in before you can comment on or make changes to this bug.