Bug 189463 - [Errno -1] Metadata file does not match checksum
[Errno -1] Metadata file does not match checksum
Status: CLOSED DUPLICATE of bug 188986
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Luke Macken
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-20 04:19 EDT by Chitlesh GOORAH
Modified: 2016-09-19 22:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-24 00:45:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chitlesh GOORAH 2006-04-20 04:19:48 EDT
Description of problem:
[Errno -1] Metadata file does not match checksum on each mirror

With FC5, everytime I yum, I fall with some checksum errors. Sometimes, yum
completes successfully, but sometimes not.

Version-Release number of selected component (if applicable):
yum-2.6.0-1

How reproducible:
Everyday, everytime

Steps to Reproduce:
1. yum install package
2.
3.
  
Actual results:


Expected results:


Additional info:
-bash-3.1# yum install *xkb*
Loading "fastestmirror" plugin
Setting up Install Process
Setting up repositories
didier                                                               [1/5]
didier                    100% |=========================|  951 B    00:00
updates                                                              [2/5]
updates                   100% |=========================|  951 B    00:00
core                                                                 [3/5]
core                      100% |=========================| 1.1 kB    00:00
aiglx                                                                [4/5]
aiglx                     100% |=========================|  951 B    00:00
extras                                                               [5/5]
extras                    100% |=========================| 1.1 kB    00:00
Loading mirror speeds from cached hostfile
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 218 kB    00:01
ftp://falkor.skane.se/pub/mirrors/fedora/updates/5/i386/repodata/primary.xml.gz:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================| 218 kB    00:01
ftp://fedora.bu.edu/fedora/core/updates/5/i386/repodata/primary.xml.gz: [Errno
-1] Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================| 218 kB    00:01
ftp://ftp.ciril.fr/pub/linux/fedora/linux/core/updates/5/i386/repodata/primary.xml.gz:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================| 218 kB    00:01
ftp://ftp.dc.aleron.net/pub/linux/fedora/linux/core/updates/5/i386/repodata/primary.xml.gz:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================| 218 kB    00:00
ftp://ftp.fu-berlin.de/linux/fedora/core/updates/5/i386/repodata/primary.xml.gz:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================| 122 kB    00:00
ftp://ftp.quicknet.nl/pub/Linux/download.fedora.redhat.com/updates/5/i386/repodata/primary.xml.gz:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================| 118 kB    00:00
ftp://ftp.rdsor.ro/pub/Linux/Distributions/Fedora/updates/5/i386/repodata/primary.xml.gz:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================| 218 kB    00:01
ftp://ftp.software.umn.edu/pub/linux/fedora/core/updates/5/i386/repodata/primary.xml.gz:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================|  24 kB    01:49
ftp://ftp.tecnoera.com/pub/fedora/linux/updates/5/i386/repodata/primary.xml.gz:
[Errno 4] Socket Error: timed out
Trying other mirror.
primary.xml.gz            100% |=========================| 161 kB    00:57
ftp://ftp.wicks.co.nz/pub/linux/dist/fedora/updates/5/i386/repodata/primary.xml.gz:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================| 218 kB    00:01
ftp://ftp.wsisiz.edu.pl/pub/linux/fedora/linux/core/updates/5/i386/repodata/primary.xml.gz:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================| 218 kB    00:01
ftp://mirror.newnanutilities.org/pub/fedora/linux/core/updates/5/i386/repodata/primary.xml.gz:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================| 218 kB    00:01
ftp://mirrors.hpcf.upr.edu/pub/Mirrors/redhat/download.fedora.redhat.com/updates/5/i386/repodata/primary.xml.gz:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================| 122 kB    00:01
ftp://mirrors.ptd.net/fedora/core/updates/5/i386/repodata/primary.xml.gz: [Errno
-1] Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================| 218 kB    00:12
http://distro.ibiblio.org/pub/linux/distributions/fedora/linux/core/updates/5/i386/repodata/primary.xml.gz:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================| 218 kB    00:01
http://fedora.colorado.edu/linux/core/updates/5/i386/repodata/primary.xml.gz:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================| 218 kB    00:01
http://fedora.inode.at/updates/5/i386/repodata/primary.xml.gz: [Errno -1]
Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================| 218 kB    00:18
http://fedora.mirrors.lug.ro/fedora/linux/core/updates/5/i386/repodata/primary.xml.gz:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================| 218 kB    00:01
http://fedora.mirrors.tds.net/pub/fedora-core/updates/5/i386/repodata/primary.xml.gz:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================| 214 kB    00:01
http://fedora.server4you.net/fedora/core/updates/5/i386/repodata/primary.xml.gz:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================| 161 kB    00:00
http://fr.rpmfind.net/linux/fedora/core/updates/5/i386/repodata/primary.xml.gz:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================| 218 kB    00:02
http://ftp.ale.org/mirrors/fedora/linux/core/updates/5/i386/repodata/primary.xml.gz:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================| 161 kB    00:01
http://ftp.chg.ru/pub/Linux/fedora/linux/core/updates/5/i386/repodata/primary.xml.gz:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================| 218 kB    00:01
http://ftp.crihan.fr/mirrors/fedora.redhat.com/fedora/linux/core/updates/5/i386/repodata/primary.xml.gz:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================| 218 kB    00:01
http://ftp.esat.net/pub/linux/fedora/updates/5/i386/repodata/primary.xml.gz:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================| 218 kB    00:03
http://ftp.iij.ad.jp/pub/linux/fedora/core/updates/5/i386/repodata/primary.xml.gz:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================| 218 kB    00:01
http://ftp.informatik.uni-frankfurt.de/fedora/core/updates/5/i386/repodata/primary.xml.gz:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================| 218 kB    00:12
http://ftp.kddilabs.jp/Linux/packages/fedora/core/updates/5/i386/repodata/primary.xml.gz:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
Comment 1 Jeremy Katz 2006-04-20 15:22:43 EDT
Does this happen without fastestmirror?
Comment 2 Chitlesh GOORAH 2006-04-20 16:18:00 EDT
Without fastest mirror
-bash-3.1# yum install gyum
Setting up Install Process
Setting up repositories
extras                                                               [2/4]
extras                    100% |=========================| 1.1 kB    00:00
updates                                                              [3/4]
updates                   100% |=========================|  951 B    00:00
core                                                                 [4/4]
core                      100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 961 kB    00:04
extras    : ################################################## 2679/2679
Added 2679 new packages, deleted 0 old in 18.25 seconds
primary.xml.gz            100% |=========================| 219 kB    00:01
updates   : ################################################## 701/701
Added 701 new packages, deleted 0 old in 6.23 seconds
primary.xml.gz            100% |=========================| 767 kB    00:03
core      : ################################################## 2207/2207
Added 2207 new packages, deleted 0 old in 16.04 seconds
Parsing package install arguments
No Match for argument: gyum
Nothing to do

-bash-3.1# yum clean all

With fastestmirror:

Loading "fastestmirror" plugin
Cleaning up Everything
0 headers removed
0 packages removed
12 metadata files removed
0 cache files removed
4 cache files removed
-bash-3.1# yum install gyum
Loading "fastestmirror" plugin
Setting up Install Process
Setting up repositories
extras                                                               [2/4]
extras                    100% |=========================| 1.1 kB    00:00
updates                                                              [3/4]
updates                   100% |=========================|  951 B    00:00
core                                                                 [4/4]
core                      100% |=========================| 1.1 kB    00:00
Loading mirror speeds from cached hostfile
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 961 kB    00:04
extras    : ################################################## 2679/2679
Added 2679 new packages, deleted 0 old in 23.53 seconds
ftp://falkor.skane.se/pub/mirrors/fedora/updates/5/i386/repodata/primary.xml.gz:
[Errno 4] IOError: [Errno ftp error] 530 Sorry, the maximum number of allowed
clients (60) are already connected.
Trying other mirror.
primary.xml.gz            100% |=========================| 219 kB    00:01
ftp://fedora.bu.edu/fedora/core/updates/5/i386/repodata/primary.xml.gz: [Errno
-1] Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================| 218 kB    00:01
updates   : ################################################## 697/697
Added 697 new packages, deleted 0 old in 6.94 seconds
primary.xml.gz            100% |=========================| 767 kB    00:03
core      : ################################################## 2207/2207
Added 2207 new packages, deleted 0 old in 16.20 seconds
Parsing package install arguments
No Match for argument: gyum
Nothing to do

It chocked twice with fastestmirror.

What is strange with fastestmirror is that im in Frankfurt, Germany right now
and fastestmirror is choosing a mirror from japan and new zealand!!
Comment 3 Jeremy Katz 2006-04-20 16:21:44 EDT
Looks like something in fastestmirror then.
Comment 4 Thomas Canniot 2006-04-20 16:28:24 EDT
Duplicate of this one : https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=188986

That I submitted 6 days ago :)
Comment 5 Chitlesh GOORAH 2006-04-20 16:35:18 EDT
same here : https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=188986
Comment 6 f4 2006-04-20 16:48:02 EDT
[root@bluebox ~]# yum clean all
Loading "installonlyn" plugin
Cleaning up Everything
0 headers removed
0 packages removed
15 metadata files removed
0 cache files removed
5 cache files removed
[root@bluebox ~]# yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
livna                                                                [1/5]
livna                     100% |=========================|  951 B    00:00
updates                                                              [2/5]
updates                   100% |=========================|  951 B    00:00
core                                                                 [3/5]
core                      100% |=========================| 1.1 kB    00:00
freshrpms                                                            [4/5]
freshrpms                 100% |=========================|  951 B    00:00
extras                                                               [5/5]
extras                    100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 125 kB    00:00
livna     : ################################################## 346/346
Added 346 new packages, deleted 0 old in 3.18 seconds
primary.xml.gz            100% |=========================| 219 kB    00:01
updates   : ################################################## 701/701
Added 701 new packages, deleted 0 old in 7.56 seconds
primary.xml.gz            100% |=========================| 767 kB    00:03
core      : ################################################## 2207/2207
Added 2207 new packages, deleted 0 old in 26.46 seconds
primary.xml.gz            100% |=========================|  54 kB    00:00
freshrpms : ################################################## 167/167
Added 167 new packages, deleted 0 old in 2.89 seconds
primary.xml.gz            100% |=========================| 787 kB    00:05
extras    : ################################################## 2235/2235
Added 2235 new packages, deleted 0 old in 35.37 seconds
No Packages marked for Update/Obsoletion



[root@bluebox ~]# yum clean all


[root@bluebox ~]# yum update
Loading "installonlyn" plugin
Loading "fastestmirror" plugin
Setting up Update Process
Setting up repositories
livna                                                                [1/5]
livna                     100% |=========================|  951 B    00:00
updates                                                              [2/5]
updates                   100% |=========================|  951 B    00:00
core                                                                 [3/5]
core                      100% |=========================| 1.1 kB    00:00
freshrpms                                                            [4/5]
freshrpms                 100% |=========================|  951 B    00:00
extras                                                               [5/5]
extras                    100% |=========================| 1.1 kB    00:00
Loading mirror speeds from cached hostfile
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 118 kB    00:00
http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/5/i386/repodata/primary.xml.gz:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================| 118 kB    00:00
http://wftp.tu-chemnitz.de/pub/linux/livna/fedora/5/i386/repodata/primary.xml.gz:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================| 125 kB    00:00
livna     : ################################################## 346/346
Added 346 new packages, deleted 0 old in 4.65 seconds
http://ftp.surfnet.nl/ftp/pub/os/Linux/distr/fedora/updates/5/i386/repodata/primary.xml.gz:
[Errno 14] HTTP Error 404: Date: Thu, 20 Apr 2006 20:38:08 GMT
Server: Apache/2.0.46 (Unix)
Content-Length: 346
Connection: close
Content-Type: text/html; charset=iso-8859-1
Trying other mirror.
primary.xml.gz            100% |=========================| 218 kB    00:00
http://ftp.crihan.fr/mirrors/fedora.redhat.com/fedora/linux/core/updates/5/i386/repodata/primary.xml.gz:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================| 218 kB    00:00
ftp://ftp.ciril.fr/pub/linux/fedora/linux/core/updates/5/i386/repodata/primary.xml.gz:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================| 219 kB    00:00
updates   : ################################################## 701/701
Added 701 new packages, deleted 0 old in 8.07 seconds
primary.xml.gz            100% |=========================| 767 kB    00:01
core      : ################################################## 2207/2207
Added 2207 new packages, deleted 0 old in 22.01 seconds
primary.xml.gz            100% |=========================|  53 kB    00:00
http://ayo.uk3.freshrpms.net/fedora/linux/5/i386/freshrpms/repodata/primary.xml.gz:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================|  54 kB    00:00
freshrpms : ################################################## 167/167
Added 167 new packages, deleted 0 old in 1.43 seconds
primary.xml.gz            100% |=========================| 958 kB    00:03
ftp://fedora.mirrors.tds.net/pub/fedora-core-extras/5/i386/repodata/primary.xml.gz:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================| 961 kB    00:03
ftp://fedora.bu.edu/fedora/extras/5/i386/repodata/primary.xml.gz: [Errno -1]
Metadata file does not match checksum
Trying other mirror.
primary.xml.gz            100% |=========================| 937 kB    00:19
extras    : ################################################## 2620/2620
Added 2620 new packages, deleted 0 old in 29.76 seconds
No Packages marked for Update/Obsoletion
Comment 7 Luke Macken 2006-04-24 00:45:36 EDT

*** This bug has been marked as a duplicate of 188986 ***

Note You need to log in before you can comment on or make changes to this bug.