Bug 189464 - hcid segfaults during reboot
Summary: hcid segfaults during reboot
Status: CLOSED DUPLICATE of bug 186101
Alias: None
Product: Fedora
Classification: Fedora
Component: bluez-utils (Show other bugs)
(Show other bugs)
Version: 5
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: David Woodhouse
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-04-20 08:40 UTC by Matthias Bayer
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-10 09:52:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matthias Bayer 2006-04-20 08:40:27 UTC
Description of problem:
hcid segfaults when rebooting system

Version-Release number of selected component (if applicable):
bluez-utils-2.25-4

How reproducible:
on the console type 'reboot' while hcid is running 

Steps to Reproduce:
1. chkconfig bluetotooth on
2. service bluetooth start
3.reboot
  
Actual results:
segmentation fault message during shutdown dialog show that hcid segfaults

Expected results:
no segfault of hcid during reboot

Additional info:

Comment 1 Need Real Name 2006-04-26 09:52:56 UTC
hcid segfaults on every shutdown on a MSI K8N Neo2 mobo
without bluetooth with FC5-x86_64 

Comment 2 David Woodhouse 2006-04-26 09:57:36 UTC
Does it do this when you just run 'service bluetooth stop'? What if you run
'service messagebus stop' before that?

Comment 3 Need Real Name 2006-04-26 10:57:47 UTC
It does NOT segfault when running 'service bluetooth stop'.
It also does NOT segfault when first running 'service messagebus stop'
and then 'service bluetooth stop'.

Comment 4 David Woodhouse 2006-09-10 09:52:01 UTC

*** This bug has been marked as a duplicate of 186101 ***


Note You need to log in before you can comment on or make changes to this bug.