Bug 189481 - Sound is broken for Tumbler-based PowerMacs running kernel-2.6.16.x
Summary: Sound is broken for Tumbler-based PowerMacs running kernel-2.6.16.x
Status: CLOSED DUPLICATE of bug 188431
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 5
Hardware: powerpc Linux
medium
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-04-20 12:57 UTC by Joseph Sacco
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-21 06:53:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joseph Sacco 2006-04-20 12:57:46 UTC
Sound is broken for Tumbler-based PowerMacs running the 2.6.16 series of
the Fedora kernel. 

/etc/modprobe.conf, shown below,

        [ignore line wrap]
        alias eth0 sungem
        alias scsi_hostadapter sym53c8xx
        alias snd-card-0 snd-powermac
        options snd-card-0 index=0
        options snd-powermac index=0
        remove snd-powermac { /usr/sbin/alsactl store 0 >/dev/null 2>&1
        || : ; }; /sbin/modprobe -r --ignore-remove snd-powermac


causes a bunch of sound related modules to be loaded:

    [i2c-powermac is built into the kernel]

        snd_powermac           54156  0          
        snd_seq_dummy           4228  0
        snd_seq_oss            43412  0
        snd_seq_midi_event      8832  1 snd_seq_oss
        snd_seq                69760  5
        snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
        snd_seq_device         10412  3
        snd_seq_dummy,snd_seq_oss,snd_seq
        snd_pcm_oss            51536  0
        snd_mixer_oss          22848  1 snd_pcm_oss
        snd_pcm               103492  2 snd_powermac,snd_pcm_oss
        snd_timer              29444  2 snd_seq,snd_pcm
        snd                    73620  8
       
snd_powermac,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
        soundcore              11844  1 snd
        snd_page_alloc         11752  1 snd_pcm

but does *not* lead to the creation of a 'sound card':

        # ls -l /proc/asound
        total 0
        -r--r--r-- 1 root root 0 Apr 17 15:53 cards
        -r--r--r-- 1 root root 0 Apr 17 15:53 devices
        -r--r--r-- 1 root root 0 Apr 17 15:53 modules
        dr-xr-xr-x 2 root root 0 Apr 17 15:53 oss
        -r--r--r-- 1 root root 0 Apr 17 15:53 pcm
        dr-xr-xr-x 2 root root 0 Apr 17 15:53 seq
        -r--r--r-- 1 root root 0 Apr 17 15:53 timers
        -r--r--r-- 1 root root 0 Apr 17 15:53 version

This problem did not exist with the 2.6.15 series of kernels.

-Joseph

Comment 1 Frank Arnold 2006-04-21 06:53:52 UTC

*** This bug has been marked as a duplicate of 188431 ***


Note You need to log in before you can comment on or make changes to this bug.