Bug 189498 - Xen UUIDs are available from Dom0, but not from DomU (fully virtualized domains)
Summary: Xen UUIDs are available from Dom0, but not from DomU (fully virtualized domains)
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xen   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Xen Maintainance List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-04-20 15:36 UTC by Robin Norwood
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-11 21:35:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robin Norwood 2006-04-20 15:36:13 UTC
Xen provides a UUID for running domains, but this UUID is only available from
dom0, not domU.  Management applications (such as RHN) need a way to associate
the domain attached to a given dom0 with the running instance.

For fully virtualized hosts, we will not be able to expose this data in /proc,
so it will need to be exposed via DMI.

See bug #189497 for UUID exposure in paravirtualized domains.

Comment 1 Daniel Berrange 2006-09-29 21:14:32 UTC
I've tested that xen > 3.0.2-31 RPMs provide SMBIOS data to fullyvirtualized
guests. Please run 'dmidecode' in a HVM guest & confirm that the UUID data
satisfies your requirements. 

Comment 2 Daniel Berrange 2007-01-11 21:35:52 UTC
This is long since fixed in both Fedora & RHEL.



Note You need to log in before you can comment on or make changes to this bug.