Bug 189517 - ConnFailTimeout in /etc/iscsi.conf is inaffective
ConnFailTimeout in /etc/iscsi.conf is inaffective
Status: CLOSED DUPLICATE of bug 189512
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: iscsi-initiator-utils (Show other bugs)
4.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Tom Coughlan
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-20 13:54 EDT by Wayne Berthiaume
Modified: 2008-04-07 01:03 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-20 14:36:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Syslog snipet of 10 second cable pull failure (62.68 KB, text/plain)
2006-04-20 13:54 EDT, Wayne Berthiaume
no flags Details

  None (edit)
Description Wayne Berthiaume 2006-04-20 13:54:40 EDT
Description of problem:
While performing 10 second short cable pulls with ConnFailTimeout=30, EMC 
PowerPath reported path failures and tresspassed LUNs. If you 
cat /sys/class/scsi_host/host6/connfail_timeout it is set to 5 and should be 
30; therefore, iscsi_sfnet sees the path failure and passes it up to EMC 
PowerPath before teh specified 30 seconds.

Version-Release number of selected component (if applicable):
4:0.1.11-2

How reproducible:
always

Steps to Reproduce:
1. set ConnFailTimeout to 30 in /etc/isci.conf
2. cat /sys/class/scsi_host/host6/connfail_timeout; it still is equal to 5
3. run 10 second cable pulls
  
Actual results:
iscsi_sfnet reports failed paths to EMC PowerPath and EMC PowerPath marks them 
DEAD and tresspasses the LUNs. After the path returns EMC PowerPath marks them 
as ALIVE and tresspasses the LUNs back.

Expected results:
iscsi_sfnet should log the session failure and hold off passing the path 
failure to EMC PowerPath until the 30 second timer has elapsed.

Additional info:
See attached syslog of failing scenario.
Also, I was unable to provide driver debug information via the initscripts 
debug level switches because iscsi_sfnet debug is no longer working. The daemon 
and driver start; however, the driver does not fully initialize.
Comment 1 Wayne Berthiaume 2006-04-20 13:54:40 EDT
Created attachment 128046 [details]
Syslog snipet of 10 second cable pull failure
Comment 2 Wayne Berthiaume 2006-04-20 14:13:58 EDT
Accidental duplicate of 189512.
Closed.
Comment 3 Andrius Benokraitis 2006-04-20 14:36:00 EDT

*** This bug has been marked as a duplicate of 189512 ***

Note You need to log in before you can comment on or make changes to this bug.