Bug 189544 - Multiple issues with i810 driver
Multiple issues with i810 driver
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-20 17:36 EDT by Kevin DeKorte
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-03 18:35:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg conf file (2.68 KB, application/octet-stream)
2006-04-20 17:36 EDT, Kevin DeKorte
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 7654 None None None Never

  None (edit)
Description Kevin DeKorte 2006-04-20 17:36:06 EDT
Description of problem:
1. When X is running and you switch to vt1, characters disappear
2. glxinfo reports up supported GL modes
3. ppracer runs VERY slow

Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-1.6.0-1

How reproducible:
100%

Steps to Reproduce:
1. Install driver
2. enabled composite support
3.
  
Actual results:
 glxgears
libGL warning: 3D driver claims to not support visual 0x4b
libGL warning: 3D driver claims to not support visual 0x23
libGL warning: 3D driver claims to not support visual 0x25
libGL warning: 3D driver claims to not support visual 0x27
libGL warning: 3D driver claims to not support visual 0x29
libGL warning: 3D driver claims to not support visual 0x2b
libGL warning: 3D driver claims to not support visual 0x2d
libGL warning: 3D driver claims to not support visual 0x2f
libGL warning: 3D driver claims to not support visual 0x31

ppracer runs 9-10fps at 800x600x32 

Expected results:
glxgears should not show any unsupported visuals

ppracer should be in the 40-50fps range minimal with this card and driver

Additional info:
Did not have these problems with FC5.
Comment 1 Kevin DeKorte 2006-04-20 17:36:07 EDT
Created attachment 128068 [details]
xorg conf file
Comment 2 Kevin DeKorte 2006-04-20 17:42:23 EDT
Disabling the composite extension does not appear to affect this problem
Comment 3 Kevin DeKorte 2006-04-20 17:43:57 EDT
Disabling composite does fix the problem with the vt console characters
disappearing.
Comment 4 Mike A. Harris 2006-05-23 09:14:46 EDT
One bug report (In reply to comment #0)
> Description of problem:
> 1. When X is running and you switch to vt1, characters disappear
> 2. glxinfo reports up supported GL modes
> 3. ppracer runs VERY slow

File individual bug reports for each issue when filing bugs in bugzilla,
as we only accept one bug per bug report.


> 2. enabled composite support


> 3.
>   
> Actual results:
>  glxgears
> libGL warning: 3D driver claims to not support visual 0x4b
> libGL warning: 3D driver claims to not support visual 0x23
> libGL warning: 3D driver claims to not support visual 0x25
> libGL warning: 3D driver claims to not support visual 0x27
> libGL warning: 3D driver claims to not support visual 0x29
> libGL warning: 3D driver claims to not support visual 0x2b
> libGL warning: 3D driver claims to not support visual 0x2d
> libGL warning: 3D driver claims to not support visual 0x2f
> libGL warning: 3D driver claims to not support visual 0x31
> 
> ppracer runs 9-10fps at 800x600x32 
> 
> Expected results:
> glxgears should not show any unsupported visuals
> 
> ppracer should be in the 40-50fps range minimal with this card and driver
> 
> Additional info:
> Did not have these problems with FC5.

Composite support is experimental.

Please report this issue to X.Org developers by filing a bug report in
the X.Org bugzilla located at http://bugs.freedesktop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Setting status to "NEEDINFO_REPORTER", awaiting X.Org bug URL
for tracking.


Comment 5 Kevin DeKorte 2006-07-27 12:04:48 EDT
Some additional information on this bug

1. Composite support works better with later drivers.
   Version 1.6.1 of the intel driver is out now. The current modeset version of
the driver in rawhide works very poorly on my machine

XOrg bug on this is https://bugs.freedesktop.org/show_bug.cgi?id=6942 and
another rawhide bug is at
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=198062

2. 3-d performance is being worked on by the Xorg/Mesa Team. Was unable to find
a bug so the following bug was opened
https://bugs.freedesktop.org/show_bug.cgi?id=7654

Comment 6 Anton Keks 2006-08-17 12:10:14 EDT
Same prbelm here with unsupported visuals.

I have the 855GM chipset, which is a bit older and seems to use i810_dri.so
instead of i915_dri.so as Mesa driver.

Strangely enought, glxgears work quite ok (haven't tried before to compare fps),
but ppracer is flickering and is imposible to play.

compiz, of course, refuses to run with the following messages:

libGL warning: 3D driver claims to not support visual 0x4b
...skipping...
libGL warning: 3D driver claims to not support visual 0x31
compiz: No stencil buffer. Clipping of transformed windows is not going to be
correct when screen is transformed.

In various forums on the internet there are posts that this problem is a Mesa
bug and is fixed in CVS. I don't know if they have released it somehow, but
maybe rpms in rawhide can be updated?

Currently, 3D stuff is unusable for all i810 users.
Comment 7 Patrice Dumas 2006-10-22 06:30:36 EDT
With Intel Corporation 82852/855GM Integrated Graphics 
xorg-x11-drv-i810-1.6.5-9.fc6
mesa-libGL-6.5.1-7.fc6

ppracer runs fine, I cannot reproduce the vt1 character disapearing,
even with composite.

There is only one visual unsupported by libGL:

glxgears
libGL warning: 3D driver claims to not support visual 0x4b

Maybe this bug could be closed?
Comment 8 Adam Jackson 2007-05-03 18:35:12 EDT
Even that message should be gone in new Mesa builds.

Marking as fixed in rawhide; please reopen if this still occurs for you.

Note You need to log in before you can comment on or make changes to this bug.