Bug 189566 - Wifi interface stopped working in kernel-2.6.16-1.2096_FC5
Wifi interface stopped working in kernel-2.6.16-1.2096_FC5
Status: CLOSED DUPLICATE of bug 191326
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-21 00:11 EDT by Geraldo Veiga
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-26 11:08:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Geraldo Veiga 2006-04-21 00:11:49 EDT
Description of problem:
I am running Fedora Core 5 with the new kernel update: kernel-2.6.16-1.2096_FC5.

After the upgrade, my wifi adaptor (D-Link DWL-650) stopped working.

Version-Release number of selected component (if applicable):
kernel-2.6.16-1.2096_FC5

Trying to enable the wifi interface gives the message:
-----
Error for wireless request "Set Mode" (8B06) :
    SET failed on device wifi0 ; Operation not supported.
-----

/var/log/messages:
----
Apr 21 00:48:35 localhost kernel: pccard: PCMCIA card inserted into slot 1
Apr 21 00:48:35 localhost kernel: pcmcia: registering new device pcmcia1.0
Apr 21 00:48:35 localhost kernel: hostap_cs: Registered netdevice wifi0
Apr 21 00:48:35 localhost kernel: hostap_cs: index 0x01: Vcc 3.3, irq 3, io
0xd100-0xd13f
Apr 21 00:48:35 localhost kernel: wifi0: NIC: id=0x800c v1.0.0
Apr 21 00:48:35 localhost kernel: wifi0: PRI: id=0x15 v1.0.7
Apr 21 00:48:35 localhost kernel: wifi0: STA: id=0x1f v1.3.5
Apr 21 00:48:35 localhost kernel: wifi0: updating basic rate set automatically
to match with the new supported rate set
Apr 21 00:48:36 localhost dhclient: wifi0: unknown hardware address type 801


How reproducible: restart network


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Lonni J Friedman 2006-04-22 14:36:22 EDT
This looks like a variant of bug 179982 (which was unfortunately closed, without
resolution):
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=179982

I'm running into a similar problem here with a Linksys WPC11v3 pcmcia wifi card.
 It used the orinoco_cs driver up until a udev update in FC4, and then all hell
broke loose.  I upgraded to FC5 2 weeks ago, and getting wireless to work at all
requires a seemingly random series of card ejects/reinserts, bringing the
interface up/down, and un/loading orinoco_cs modules.  

It seems that part of the problem is that both the orinoco_cs and hostap_cs
modules are claiming ownership of my hardware.  Even when I tried blacklisting
hostap_cs, I still can't get networking.
Comment 2 Geraldo Veiga 2006-04-22 19:17:06 EDT
An addendum to my original report:

D-Link DWL-650 had been working with FC5.  I am  using it right now with the
previous kernel release: kernel-2.6.16-1.2080_FC5.
Comment 3 Geraldo Veiga 2006-05-08 08:33:17 EDT
Same problem with kernel-2.6.16-1.211_FC5.
Comment 4 Mace Moneta 2006-05-10 11:43:56 EDT
I'm seeing the same problem with a Linksys WPC11v3 on 2.6.16-1.2111_FC5.  I just
performed a clean install (previously had FC4 on the machine) and the wireless
card staopped working.

# pccardctl ident

Socket 0:
  no product info available
Socket 1:
  product info: "The Linksys Group, Inc.", "Instant Wireless Network PC Card",
"", ""
  manfid: 0x0274, 0x1613
  function: 6 (network)

May 10 11:48:51 firefly kernel: pccard: PCMCIA card inserted into slot 1
May 10 11:48:51 firefly kernel: pcmcia: registering new device pcmcia1.0
May 10 11:48:51 firefly kernel: hostap_cs: Registered netdevice wifi0
May 10 11:48:51 firefly kernel: hostap_cs: index 0x01: Vcc 3.3, irq 3, io
0xd100-0xd13f
May 10 11:48:52 firefly kernel: wifi0: NIC: id=0x801b v1.0.0
May 10 11:48:52 firefly kernel: wifi0: PRI: id=0x15 v1.1.0
May 10 11:48:52 firefly kernel: wifi0: STA: id=0x1f v1.4.2
May 10 11:48:52 firefly kernel: wifi0: Warning: secondary station firmware
version 1.4.2 does not seem to work in Host AP mode
May 10 11:48:52 firefly kernel: wifi0: updating basic rate set automatically to
match with the new supported rate set
May 10 11:48:52 firefly dhclient: wifi0: unknown hardware address type 801
May 10 11:48:53 firefly dhclient: dhclient(11754) is already running - exiting.
May 10 11:48:53 firefly dhclient: exiting.
May 10 11:48:53 firefly dhclient: wifi0: unknown hardware address type 801
May 10 11:48:53 firefly dhclient: DHCPDISCOVER on wifi0 to 255.255.255.255 port
67 interval 5
May 10 11:48:53 firefly kernel: ADDRCONF(NETDEV_CHANGE): wifi0: link becomes ready
May 10 11:48:58 firefly dhclient: DHCPDISCOVER on wifi0 to 255.255.255.255 port
67 interval 10
May 10 11:49:08 firefly dhclient: DHCPDISCOVER on wifi0 to 255.255.255.255 port
67 interval 12
May 10 11:49:20 firefly dhclient: DHCPDISCOVER on wifi0 to 255.255.255.255 port
67 interval 17
May 10 11:49:37 firefly dhclient: DHCPDISCOVER on wifi0 to 255.255.255.255 port
67 interval 17
May 10 11:49:54 firefly dhclient: No DHCPOFFERS received.
May 10 11:49:54 firefly NetworkManager: <information>   wlan0: Device is
fully-supported using driver 'hostap_cs'.
May 10 11:49:54 firefly NetworkManager: <information>   nm_device_init():
waiting for device's worker thread to start
May 10 11:49:54 firefly NetworkManager: <information>   nm_device_init():
device's worker thread started, continuing.
May 10 11:49:54 firefly NetworkManager: <information>   Now managing wireless
(802.11) device 'wlan0'.
May 10 11:49:54 firefly NetworkManager: <information>   Deactivating device wlan0.
May 10 11:49:55 firefly kernel: ADDRCONF(NETDEV_CHANGE): wifi0: link becomes ready
May 10 11:49:55 firefly kernel: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready

Comment 5 Mace Moneta 2006-05-10 11:45:26 EDT
Some more information from dmesg:

pccard: PCMCIA card inserted into slot 1
pcmcia: registering new device pcmcia1.0
hostap_cs: setting Vcc=33 (constant)
hostap_cs: setting Vcc=33 (from config)
Checking CFTABLE_ENTRY 0x01 (default 0x01)
IO window settings: cfg->io.nwin=1 dflt.io.nwin=1
io->flags = 0x0046, io.base=0x0000, len=64
hostap_cs: Registered netdevice wifi0
wifi0: Interrupt, but dev not OK
hostap_cs: index 0x01: Vcc 3.3, irq 3, io 0xd100-0xd13f
prism2_hw_init: initialized in 200 ms
wifi0: NIC: id=0x801b v1.0.0
wifi0: PRI: id=0x15 v1.1.0
wifi0: STA: id=0x1f v1.4.2
wifi0: defaulting to host-based encryption as a workaround for firmware bug in H
ost AP mode WEP
wifi0: defaulting to bogus WDS frame as a workaround for firmware bug in Host AP
 mode WDS
wifi0: Warning: secondary station firmware version 1.4.2 does not seem to work i
n Host AP mode
wifi0: registered netdevice wlan0
prism2: wifi0: operating mode changed 3 -> 2
wifi0: updating basic rate set automatically to match with the new supported rat
e set
wifi0: LinkStatus=2 (Disconnected)
wifi0: LinkStatus: BSSID=44:44:44:44:44:44
wifi0: LinkStatus=2 (Disconnected)
wifi0: LinkStatus: BSSID=44:44:44:44:44:44
wifi0: LinkStatus=2 (Disconnected)
wifi0: LinkStatus: BSSID=44:44:44:44:44:44
wifi0: LinkStatus=1 (Connected)
wifi0: LinkStatus: BSSID=00:40:f4:e3:bf:bc
ADDRCONF(NETDEV_CHANGE): wifi0: link becomes ready
wifi0: invalid skb->cb magic (0x00000000, expected 0xf08a36a2)
wifi0: invalid skb->cb magic (0x00000000, expected 0xf08a36a2)
wifi0: invalid skb->cb magic (0x00000000, expected 0xf08a36a2)
wifi0: invalid skb->cb magic (0x00000000, expected 0xf08a36a2)
wifi0: LinkStatus=2 (Disconnected)
wifi0: LinkStatus: BSSID=00:40:f4:e3:bf:bc
wifi0: LinkStatus=1 (Connected)
wifi0: LinkStatus: BSSID=00:40:f4:e3:bf:bc
ADDRCONF(NETDEV_CHANGE): wifi0: link becomes ready
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
wlan0: no IPv6 routers present
Comment 6 Geraldo Veiga 2006-05-25 16:09:07 EDT
Same problem with kernel-2.6.16-1.2122_FC5.
Comment 7 Geraldo Veiga 2006-05-26 11:08:33 EDT
It turns out that this is an incompatibility between the orinoco_cs and
hostap_cs. I am not sure of why hostap_cs is being loaded in my configuration --
Is this the bug? --, but if it is blacklisted, the wifi interface works
correctly in kernel-2.6.16-1.2122_FC5.

I added the following to /etc/modprobe.d/blacklist

# Wireless LAN card
blacklist hostap_cs

This work around is described in a similar bug report:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=191326






*** This bug has been marked as a duplicate of 191326 ***

Note You need to log in before you can comment on or make changes to this bug.