Bug 189571 - growisofs fails when burning a dvd+rw
growisofs fails when burning a dvd+rw
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dvd+rw-tools (Show other bugs)
6
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
:
: 211833 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-21 03:57 EDT by Martin
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version: 7.0-0.fc5.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-21 06:54:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin 2006-04-21 03:57:06 EDT
Description of problem:
When using K3B to burn a DVD-RW I get the following error:
:-( next session would cross 4GB boundary, aborting...

Version-Release number of selected component (if applicable):
dvd+rw-tools-6.1-0.FC5.2.i386.rpm

How reproducible:
Start K3B and try to create a DVD-RW on the fly

Steps to Reproduce:
1. Create a new DVD-Data project
2. burn DVD
3. growisofs will fail
  
Actual results:
:-( next session would cross 4GB boundary, aborting...

Expected results:
Create a data DVD with DVD+RW as it did in FC4

Additional info:
System
-----------------------
K3b Version: 0.12.15

KDE Version: 3.5.2-0.1.fc5 Red Hat
QT Version:  3.3.5
Kernel:      2.6.16-1.2096_FC5
Devices
-----------------------
PLEXTOR DVDR   PX-716A 1.08 (/dev/hdd, ) at  [CD-R; CD-RW; CD-ROM;
DVD-ROM; DVD-R; DVD-RW; DVD-R DL; DVD+R; DVD+RW; DVD+R DL] [DVD-ROM; DVD-R
Sequential; DVD-R Dual Layer Sequential; DVD-RW Restricted Overwrite; DVD-RW
Sequential; DVD+RW; DVD+R; DVD+R Double Layer; CD-ROM; CD-R; CD-RW] [SAO; TAO;
RAW; SAO/R96P; SAO/R96R; RAW/R16; RAW/R96P; RAW/R96R; Restricted Overwrite]

TOSHIBA DVD-ROM SD-M1712 1004 (/dev/hdc, ) at  [CD-ROM; DVD-ROM] [DVD-ROM;
CD-ROM] [None] Used versions
-----------------------
growisofs: 6.1
mkisofs: 2.1.1a03

growisofs
-----------------------
:-( next session would cross 4GB boundary, aborting...

growisofs command:
-----------------------
/usr/bin/growisofs -M /dev/hdd -use-the-force-luke=notray
-use-the-force-luke=tty -speed=4 -use-the-force-luke=bufsize:32m -gui
-graft-points -volid K3b data project -volset  -appid K3B THE CD KREATOR
(C) 1998-2005 SEBASTIAN TRUEG AND THE K3B TEAM -publisher  -preparer -sysid
LINUX -volset-size 1 -volset-seqno 1 -sort /tmp/kde-root/k3bJBhFka.tmp
-rational-rock -hide-list /tmp/kde-root/k3bGujT4a.tmp -joliet -hide-joliet-list
/tmp/kde-root/k3bs04vda.tmp -full-iso9660-filenames -iso-level 2 -path-list
/tmp/kde-root/k3bojXhUb.tmp


# /usr/bin/dvd+rw-mediainfo /dev/hdd
INQUIRY:                [PLEXTOR ][DVDR   PX-716A  ][1.08]
GET [CURRENT] CONFIGURATION:
 Mounted Media:         1Ah, DVD+RW
 Media ID:              PHILIPS/041
 Current Write Speed:   4.0x1385=5540KB/s
 Write Speed #0:        4.0x1385=5540KB/s
GET [CURRENT] PERFORMANCE:
 Write Performance:     4.0x1385=5540KB/s@[0 -> 2271103]
 Speed Descriptor#0:    03/2295103 R@12.0x1385=16620KB/s
W@4.0x1385=5540KB/s
READ DVD STRUCTURE[#0h]:
 Media Book Type:       92h, DVD+RW book [revision 2]
 Legacy lead-out at:    2271104*2KB=4651220992
READ DISC INFORMATION:
 Disc status:           complete
 Number of Sessions:    1
 State of Last Session: complete
 Number of Tracks:      1
 BG Format Status:      suspended
READ TRACK INFORMATION[#1]:
 Track State:           complete incremental
 Track Start Address:   0*2KB
 Free Blocks:           0*2KB
 Track Size:            2295104*2KB
READ CAPACITY:          2295104*2048=4700372992


Workaround:
use dvd+rw-tools-5.21.4.10.8-6.2.1.i386 with this version there
exists no problem
Comment 1 Martin 2006-04-21 16:15:08 EDT
dvd+rw-tools-6.1-0.FC5.2:
after formating der dvd+rw disc and attempt to write a new dvd+rw data project
to disc, i get the following error message:

:-( unable to anonymously mmap 33554432: Resource temporarily unavailable

Solution:
The problem is gone, because i build a rpm package with the PLD src.rpm from:
http://ep09.kernel.pl/dists/3.0/PLD/SRPMS/RPMS/dvd+rw-tools-6.1-1.src.rpm

This source package includes this three patches:
dvd+rw-tools-bacula.patch
dvd+rw-tools-makefile.patch
dvd+rw-tools-printf.patch

could you please verify this patches
Comment 2 Henri Ala-Peijari 2006-10-24 16:52:30 EDT
This problem exisested in FC6Pre-Release. I upgraded to FC6 (released today) and
this problem still exsists.
Comment 3 Henri Ala-Peijari 2006-11-03 10:28:29 EST
Could someone with authority please change the version to FC6 from FC5 so that
someone would actually bother with this report.
Comment 4 Harald Hoyer 2006-11-03 11:05:59 EST
update to testing will be pushed soon..
Comment 5 Bastien Nocera 2006-12-01 06:45:12 EST
*** Bug 211833 has been marked as a duplicate of this bug. ***
Comment 6 Bastien Nocera 2006-12-01 06:47:15 EST
See the patch in bug 215818
Comment 7 Henri Ala-Peijari 2007-03-09 03:25:45 EST
Am I the only one that still has this problem? I have all the yum updates for
Fedora 6 but I still have this problem... 
Comment 8 Tim Waugh 2007-03-09 04:17:03 EST
I no longer see this problem.
Comment 9 Henri Ala-Peijari 2007-03-09 06:21:17 EST
Maby my problem is related to something else, since I can't use cdrecord either.
My output from k3b debug:

System
-----------------------
K3b Version: 0.12.17

KDE Version: 3.5.6-0.3.fc6 Fedora-Core
QT Version:  3.3.7
Kernel:      2.6.19-1.2911.6.5.fc6xen
Devices
-----------------------
ATAPI CD-ROM 50X 196C (/dev/hdd, ) at  [CD-ROM] [Error] [None]

_NEC DVD_RW ND-2500A 1.0A (/dev/hdc, ) at  [CD-R; CD-RW; CD-ROM; DVD-ROM; DVD-R;
DVD-RW; DVD+R; DVD+RW] [DVD-ROM; DVD-R Sequential; DVD-RW Restricted Overwrite;
DVD-RW Sequential; DVD+RW; DVD+R; CD-ROM; CD-R; CD-RW] [SAO; TAO; RAW; SAO/R96P;
SAO/R96R; RAW/R16; RAW/R96P; RAW/R96R; Restricted Overwrite]
Used versions
-----------------------
growisofs: 7.0
mkisofs: 2.1

growisofs
-----------------------
:-( unable to anonymously mmap 33554432: Resource temporarily unavailable

growisofs command:
-----------------------
/usr/bin/growisofs -M /dev/hdc -use-the-force-luke=notray
-use-the-force-luke=tty -speed=4 -use-the-force-luke=bufsize:32m -gui
-graft-points -volid K3b data project -volset  -appid K3B THE CD KREATOR (C)
1998-2005 SEBASTIAN TRUEG AND THE K3B TEAM -publisher  -preparer  -sysid LINUX
-volset-size 1 -volset-seqno 1 -sort /tmp/kde-root/k3bRW5lnb.tmp -rational-rock
-hide-list /tmp/kde-root/k3bmM3QRa.tmp -joliet -hide-joliet-list
/tmp/kde-root/k3bmdUsnc.tmp -full-iso9660-filenames -iso-level 2 -path-list
/tmp/kde-root/k3bgb0VXa.tmp 

* * * * * * * *
To make things worse, I can't use cdrecord either (works fine with my FC5, but
not on this FC6 installation on the same computer). cdrecord output:
* * * * * * * *
[root@luopio ~]# cdrecord -scanbus
Cdrecord-Clone 2.01 (cpu-pc-linux-gnu) Copyright (C) 1995-2004 J�rg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to
http://bugzilla.redhat.com/bugzilla
Note: The author of cdrecord should not be bothered with problems in this version.
cdrecord: Invalid or incomplete multibyte or wide character. Cannot open SCSI
driver.
cdrecord: For possible targets try 'cdrecord -scanbus'.
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.
[root@luopio ~]# 


Comment 10 Martin 2007-03-09 12:03:27 EST
a solution for me was to increase the buffersize of growisofs with:
-use-the-force-luke=bufsize:16m

or in k3b under settings - configure k3b - Advanced
- Manual writing buffer size: 16MB
Comment 11 Henri Ala-Peijari 2007-03-10 03:36:28 EST
Thanks. Increasing the buffer seemed to solve this for me also.

Note You need to log in before you can comment on or make changes to this bug.