Bug 189579 - sonypi module not autoloading
sonypi module not autoloading
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-21 07:38 EDT by Miles Sabin
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-21 07:42:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miles Sabin 2006-04-21 07:38:12 EDT
I've just upgraded my Sony PGC-Z1XSP from FC3 to FC5, and I'm having a 
problem getting the sonypi module to load on boot (a manual modprobe 
sonypi works perfectly). This is almost certainly a udev problem, and I 
had it working perfectly with udev under FC3, but things have changed a 
little since then and I'm out of ideas so any suggestions would be most 
welcome.

I have the following in my modprobe.conf,

  alias char-major-10-250 sonypi
  options sonypi minor=250

and I've added the following files,

  /etc/makedev.d/01sonypi:

  c $CONSOLE 10 250 1 1 sonypi

and,

  /etc/udev.d/rules.d/60-sonypi.rules:

  KERNEL="sonypi", NAME="%k", MODE="0666"

but with no discernable effect ... can anyone give me any pointers to 
what I'm missing?
Comment 1 Harald Hoyer 2006-04-21 07:42:49 EDT
I guess the sonypi has no sysfs entry ("dev") in /sys .
Just create a file in /etc/udev/makedev.d/
51-sonypi.nodes:
sonypi
Comment 2 Miles Sabin 2006-04-21 17:00:54 EDT
Thanks for that. I tried following your advice, and on boot I now get the
following error message,

  Starting udev: error parsing "/etc/makedev.d/51-sonypi.nodes" : unknown group
in "sonypi"

Immediately after boot,

  find /sys -name "*sony*" -print

finds nothing, but after a manual modprobe sonypi it gives me,

  /sys/module/sonypi
  /sys/class/misc/sonypi
  /sys/bus/platform/drivers/sonypi
  /sys/bus/platform/drivers/sonypi/sonypi
  /sys/bus/platform/devices/sonypi
  /sys/devices/platform/sonypi

Any hints on how to proceed from here would be much appreciated.
Comment 3 Miles Sabin 2006-04-21 17:09:37 EDT
Ignore that last comment: I created the file in /etc/makedev.d rather than
/etc/udev/makedev.d. With it installed in the right place the device node is
created as expected.

Note You need to log in before you can comment on or make changes to this bug.