Bug 189600 - 'null' config values showing up in rhn.conf
'null' config values showing up in rhn.conf
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
410
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike McCune
Corey Welton
:
Depends On:
Blocks: 171660
  Show dependency treegraph
 
Reported: 2006-04-21 11:03 EDT by Mike McCune
Modified: 2007-08-06 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version: rhn410
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-19 15:22:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McCune 2006-04-21 11:03:14 EDT
This most likely has to do with the recent change in the java Config system
where I set empty strings to null instead of quote quote ("")
Comment 1 Beth Nackashi 2006-04-22 14:54:16 EDT
cwelton is QA contact for satellite installer
Comment 2 Mike McCune 2006-04-24 10:22:48 EDT
TESTPLAN:

1) Go to the General Config page (Satellite Tools -> General Config)
2) Make sure the Proxy inputs are blank (they dont say null)
3) Submit the form.
4) examine the /etc/rhn/rhn.conf and look for:

#option generated from rhn-config-satellite.pl
server.satellite.http_proxy_username=

#option generated from rhn-config-satellite.pl
server.satellite.http_proxy=

5) Make sure those values are as above and *NOT* like this:

server.satellite.http_proxy=null

Comment 3 Mike McCune 2006-05-02 16:09:05 EDT
moving to ON_QA
Comment 4 Corey Welton 2006-05-10 14:00:42 EDT
QA Verified: No strings of "null" appear in the above config file.
Comment 5 Beth Nackashi 2006-07-19 15:22:23 EDT
moving to closed - currentrelease

Note You need to log in before you can comment on or make changes to this bug.