Bug 189618 - st0 device busy when using block size > 384k
st0 device busy when using block size > 384k
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-21 14:15 EDT by Norco IS
Modified: 2015-05-27 11:33 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.6.17-1.2142_FC4smp
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-21 12:04:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace output (8.98 KB, text/plain)
2006-04-24 18:24 EDT, Norco IS
no flags Details
strace -f output (9.65 KB, text/plain)
2006-04-25 11:44 EDT, Norco IS
no flags Details

  None (edit)
Description Norco IS 2006-04-21 14:15:32 EDT
Description of problem:

When trying to access tape device (/dev/st0) get an error that indicates that
device is busy.


Version-Release number of selected component (if applicable):
star rpm: star-1.5a54-2
kernel: kernel-smp-2.6.16-1.2096_FC4

How reproducible:

Always

Steps to Reproduce:
1. star -tv -bs=512k -fs=32m -file=/dev/st0

(write to the tape with star produces the same result)
  
Actual results:
star: Device or resource busy. Error reading '/dev/st0'.
star: 0 blocks + 0 bytes (total of 0 bytes = 0.00k).

`echo $?`
gives: 16

Expected results:

Listing of tape contents

Additional info:

Does not seem to be a problem with the device as using:
tar tvf /dev/st0
and
tar cvf /dev/st0 ......
works fine.

Workaround - revert back to old kernel. Using kernel 2.6.15-1.1833_FC4smp works
fine.
Comment 1 Peter Vrabec 2006-04-24 04:41:12 EDT
Could you send strace output, please? Thx. 
Comment 2 Norco IS 2006-04-24 18:24:04 EDT
Created attachment 128168 [details]
strace output
Comment 3 Peter Vrabec 2006-04-25 08:57:06 EDT
use strace -f please  
Comment 4 Norco IS 2006-04-25 11:44:22 EDT
Created attachment 128207 [details]
strace -f output
Comment 5 Peter Vrabec 2006-04-26 05:50:02 EDT
does   
$dd if=/dev/zero of=/tmp/foo bs=512k count=1  
works for you?  
  
Could you try the latest star from devel?  
Comment 6 Peter Vrabec 2006-04-26 06:44:47 EDT
ooops,   
change command dd in comment #5 to 
$dd if=/dev/zero of=/dev/st0 bs=512k count=1  
Comment 7 Norco IS 2006-04-26 11:51:45 EDT
The dd command didn't work. Gave:
dd: writing '/dev/st0': Device or resource busy

I tried different 'bs=' values. Found that the dd command works when bs=384k but
not when it is bs=385k.
Perhaps this is not a star problem at all! Could it be a kernel or st module
problem?
I could try the latest devel star if you still think that it would be useful. 
Comment 8 Peter Vrabec 2006-04-26 14:02:27 EDT
Yes, it could be a kernel problem. I think it's not necessary to try another 
star. 
Comment 9 Norco IS 2006-07-21 12:04:19 EDT
This seems to have been resolved with installation of kernel 2.6.17-1.2142_FC4smp
Comment 10 Todd Zervas 2015-05-27 11:33:18 EDT
This problem has re-appeared(?) in RHEL 6.6    2.6.32-504.16.2.el6.x86_64

# mt -f /dev/nst0 rewind
# mt -f /dev/nst0 status
SCSI 2 tape drive:
File number=0, block number=0, partition=0.
Tape block size 0 bytes. Density code 0x46 (LTO-4).
Soft error count since last status=0
General status bits on (41010000):
 BOT ONLINE IM_REP_EN
# dd if=/dev/zero of=/dev/st0 bs=512k count=1
dd: writing `/dev/st0': Device or resource busy
1+0 records in
0+0 records out
0 bytes (0 B) copied, 4.18458 s, 0.0 kB/s

Note You need to log in before you can comment on or make changes to this bug.