Bug 189643 - Totem crash if i have a .txt file in the folder of the selected file.
Totem crash if i have a .txt file in the folder of the selected file.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gstreamer-plugins-base (Show other bugs)
5
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Adam Jackson
http://fedoraproject.org/wiki/DocsPro...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-21 20:23 EDT by Ví­ctor Daniel
Modified: 2008-08-02 19:40 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.10.11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-26 12:01:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 339366 None None None Never

  None (edit)
Description Ví­ctor Daniel 2006-04-21 20:23:50 EDT
(I do not speak well English :)

I have Fedora Core 5 installed in my PC (totem is update):

if I have a text file (txt) in same folder of the average file and these have
the same name (for example, sound.mp3 and sound.txt), Totem Crashes.

I have lame (mp3 plugin) because i update the gstreamer 0.10 from
http://gstreamer.freedesktop.org/pkg/fedora/5/0.10/i386/.

Also I will report this bug in gstreamer.org.
Comment 1 John Thacker 2006-04-23 12:10:18 EDT
I can confirm this.  I can also confirm that this happens when playing a
filename.ogg file if filename.txt also exists in the same directory.
It doesn't seem to happen if filename.extension exists for extensions other
than .txt

Well, I don't get a crash, I get a hang in both cases.
Comment 2 John Thacker 2006-04-23 12:12:55 EDT
Also happens for .avi and any other extension, if filename.txt exists.
Comment 3 John Thacker 2006-04-23 12:22:35 EDT
Ah, I'm pretty sure I know what happens.
The same thing will happen if filename.asc, .sub, etc. exist.

filename.txt is one of the default locations for totem to look
for subtitles of the currently playing file.  If filename.txt 
exists, totem tries to read it as subtitles for the file.  If
it's not a valid subtitle file (and possibly if you're trying
to play something that doesn't support subtitles), it hangs.
Comment 4 John Thacker 2006-04-23 15:40:33 EDT
Filed against Totem upstream as gnome bug 339492
Comment 5 John Thacker 2006-04-24 11:16:51 EDT
Sorry, didn't see that the main reporter had already filed a bug upstream. 
Switching upstream bug link.
Comment 6 John Thacker 2006-10-25 14:59:27 EDT
Fixed in upstream CVS of gstreamer-plugins-base (no release yet).  Changing
component to gstreamer-plugins-base.
Comment 7 Bastien Nocera 2007-02-01 09:29:56 EST
Was fixed in gstreamer-plugins-base 0.10.11.
Comment 8 Bastien Nocera 2007-04-11 10:06:32 EDT
gstreamer-plugins-base 0.10.11 is in FC-6 now. I would advise an upgrade to FC-6
to get this bug fixed.
Comment 9 John Thacker 2007-04-12 08:15:35 EDT
Has it finally become an update, then?  gstreamer-plugins-base 0.10.11 has been
in the FC-6 branch on CVS for two months, but (at least through the builds two
days ago) has never been released as an update for some reason.
Comment 10 Bastien Nocera 2007-04-12 11:35:19 EDT
(In reply to comment #9)
> Has it finally become an update, then?  gstreamer-plugins-base 0.10.11 has been
> in the FC-6 branch on CVS for two months, but (at least through the builds two
> days ago) has never been released as an update for some reason.

Seems not. I'll do that now.
Comment 11 Fedora Update System 2007-04-13 15:35:43 EDT
gstreamer-0.10.11-1.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 12 Fedora Update System 2007-04-17 08:43:30 EDT
gstreamer-0.10.11-1.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 13 Bastien Nocera 2007-04-17 08:53:15 EDT
(In reply to comment #12)
> gstreamer-0.10.11-1.fc6 has been pushed for fc6, which should resolve this
issue.  If these problems are still present in this version, then please make
note of it in this bug report.

Ignore that. The fix is in gstreamer-plugins-base, which I'm building now.
Comment 14 Bastien Nocera 2007-04-17 09:10:52 EDT
Pushed gstreamer-plugins-base-0.10.11-1.fc6 to updates-testing. Let me know
whether it works.
Comment 15 John Thacker 2007-04-27 09:22:16 EDT
Still haven't seen the gstreamer-plugins-base update hit updates-testing yet. 
The gstreamer packages did a few weeks ago.
Comment 16 Bastien Nocera 2007-04-27 09:30:42 EDT
Looks like I forgot to push a button. *sigh* Done now.
Comment 17 Adam Jackson 2008-03-26 12:01:47 EDT
Eleven months old, closing.

Note You need to log in before you can comment on or make changes to this bug.