Bug 189661 - "yum remove <pkg>" doesn't remove dependencies
"yum remove <pkg>" doesn't remove dependencies
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-22 04:32 EDT by James Hunt
Modified: 2014-01-21 17:54 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-24 13:20:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Hunt 2006-04-22 04:32:19 EDT
Description of problem:

Running "yum remove <pkg>" doesn't clean up the dependencies for <pkg>.

Version-Release number of selected component (if applicable):

yum-2.6.0-1

How reproducible:

Always.

Steps to Reproduce:
1. Ensure xemacs not installed.
2. yum -y install xemacs
This installs the following packages, due to xemacs dependencies:

Canna-libs
FreeWnn-libs
neXtaw
xemacs
xemacs-common
xemacs-sumo

3. yum remove xemacs
  
Actual results:

The xemacs package is removed. However, the following packages are not removed,
even though clearly they are not required by any other package on the system:

Canna-libs
FreeWnn-libs
neXtaw
xemacs-common
xemacs-sumo

Expected results:

I would have expected all the packages that xemacs depends on, and which are not
required by other packages, to be removed.

Additional info:
Comment 1 Jeremy Katz 2006-04-24 13:20:22 EDT
yum remove <pkg> does remove all things that depend on package, but not vice
versa as there's no real way to know that nothing else on the system (including
things built or installed by hand) don't depend on them.

If you install the yum-utils package, there is a utility called package-cleanup
which can help you to find leaf node packages and remove them.

Note You need to log in before you can comment on or make changes to this bug.