Bug 189679 - Old officially released updates deleted?
Old officially released updates deleted?
Status: CLOSED NOTABUG
Product: Fedora Infrastructure
Classification: Retired
Component: update system (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Luke Macken
Bill Nottingham
http://download.fedora.redhat.com/pub...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-22 17:55 EDT by František Dvořák
Modified: 2016-09-19 22:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-24 10:28:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description František Dvořák 2006-04-22 17:55:02 EDT
Description of problem:

  I can't find some old packages in updates. It's a feature or a bug? :-)

Version-Release number of selected component (if applicable):

  For example package from Fedora Core 3: xorg-x11-6.8.2-1.FC3.13

How reproducible:

  Look at: http://download.fedoralegacy.org/fedora/3/updates/SRPMS/

Steps to Reproduce:

  wget http://download.fedora.redhat.com/pub/fedora/linux/core/updates/3/SRPMS/
-O - 2>/dev/null | sed -e 's,.*<a href="\([^"]*\)".*,\1,' | grep xorg
  
Actual results:

fonts-xorg-6.8.2-0.FC3.1.src.rpm
xorg-x11-6.8.1-12.FC3.21.src.rpm
xorg-x11-6.8.2-1.FC3.45.2.src.rpm

Expected results:

fonts-xorg-6.8.2-0.FC3.1.src.rpm
xorg-x11-6.8.1-12.FC3.21.src.rpm
xorg-x11-6.8.2-1.FC3.13.src.rpm
xorg-x11-6.8.2-1.FC3.45.src.rpm
xorg-x11-6.8.2-1.FC3.45.1.src.rpm
xorg-x11-6.8.2-1.FC3.45.2.src.rpm
...

Additional info:

  I'm searching the old packages because of searching some old bug in xorg (LID
switch corupts video in i810 for xorg > 6.8.2-1.FC3.13).
  I think for such rare cases can be good to keep whole history of all official
releases and updates...

Thank you,
  Frantisek
Comment 1 Jesse Keating 2006-04-24 10:28:46 EDT
Our updates are pruned so that we aren't keeping many copies of oudated updates
on the file server.  Mirrors appreciate this greately.  We can't keep every copy
of every outdated update as it grows the space needed quite significantly (think
of a couple OO.org updates or kernel udpates).

If you think you need every update, do rsync from a mirror w/out the --delete
option.

Note You need to log in before you can comment on or make changes to this bug.