Bug 189702 - kwin SIGSEGV on <Alt>-Tab
kwin SIGSEGV on <Alt>-Tab
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-23 09:36 EDT by Garry T. Williams
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-28 06:37:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Garry T. Williams 2006-04-23 09:36:58 EDT
Description of problem: kwin SIGSEGV on <Alt>-Tab


Version-Release number of selected component (if applicable): FC5 (updated from
FC4): kdebase-3.5.2-0.2.fc5


How reproducible: start some application and minimize it


Steps to Reproduce:
1. minimize an application window
2. hit <Alt>-Tab
  
Actual results:
kwin crashes with SIGSEGV

Expected results:
window selector displayed and switch to minimized app

Additional info:
(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
`shared object read from target memory' has disappeared; keeping its symbols.
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1209119904 (LWP 16678)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0x00e67135 in KWinInternal::Workspace::nextFocusChainClient ()
   from /usr/lib/libkdeinit_kwin.so
#7  0x00e67712 in KWinInternal::TabBox::createClientList ()
   from /usr/lib/libkdeinit_kwin.so
#8  0x00e68683 in KWinInternal::TabBox::reset ()
   from /usr/lib/libkdeinit_kwin.so
#9  0x00e690d5 in KWinInternal::Workspace::startKDEWalkThroughWindows ()
   from /usr/lib/libkdeinit_kwin.so
#10 0x00e69227 in KWinInternal::Workspace::slotWalkThroughWindows ()
   from /usr/lib/libkdeinit_kwin.so
#11 0x00e4ee58 in KWinInternal::Workspace::qt_invoke ()
   from /usr/lib/libkdeinit_kwin.so
#12 0x00a22dad in KGlobalAccelPrivate::activate ()
   from /usr/lib/libkdecore.so.4
#13 0x00a8a540 in KGlobalAccelPrivate::x11KeyPress ()
   from /usr/lib/libkdecore.so.4
#14 0x00a8a74c in KGlobalAccelPrivate::x11Event ()
   from /usr/lib/libkdecore.so.4
#15 0x00acb0d3 in KApplication::x11EventFilter ()
   from /usr/lib/libkdecore.so.4
#16 0x00e64176 in KWinInternal::Application::x11EventFilter ()
   from /usr/lib/libkdeinit_kwin.so
#17 0x010a9db4 in qt_set_x11_event_filter ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#18 0x010ba5ed in QApplication::x11ProcessEvent ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#19 0x010cca7b in QEventLoop::processEvents ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#20 0x0113db35 in QEventLoop::enterLoop ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#21 0x0113d9de in QEventLoop::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#22 0x0112405f in QApplication::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#23 0x00e652c3 in kdemain () from /usr/lib/libkdeinit_kwin.so
#24 0x0088f534 in kdeinitmain () from /usr/lib/kde3/kwin.so
#25 0x0804e3ff in ?? ()
#26 0x0804eb49 in ?? ()
#27 0x0804f048 in ?? ()
#28 0x0804f8ec in ?? ()
#29 0x005a77e4 in __libc_start_main () from /lib/libc.so.6
#30 0x0804b7e1 in ?? ()
Comment 1 Ondrej Svejda 2006-04-23 16:54:21 EDT
Happens even with no app running.
Comment 2 Garry T. Williams 2006-04-23 18:18:35 EDT
(In reply to comment #1)
> Happens even with no app running.

I can confirm this.

Steps to reproduce:

1. Shut down all apps
2. Hit <Alt>-Tab

or

1. Select a workspace with no running apps
2. Hit <Alt>-Tab

Actual results:
SIGSEGV in kwin

Expected results:
Window containing something like "*** No Active Applications ***".  (I can't
actually produce this, so the contents of the window may be slightly different.)

This behavior happened after updating FC5 with yum.  Unfortunaltely, I cannot
say what change actually caused it.  I have been keeping up to date every few
days with the Fedora updates available repository since undating to FC5.

Additional information:
-----------------------

I note that the run command window will not accept input in the command text box
after kwin crashes.  I can select "kwin" from the drop-down, however (after
actually typing it in before the crash :-)).  A restart looks fine except the
settings for the workspace switcher have been changed to two rows without it
changing its appearance in the panel.  (Accelerator keys for switch right skip a
workspace.)  I can restore this by setting the Pager Options->Rows to 2 then
back to one.
Comment 3 Ngo Than 2006-04-28 06:37:44 EDT
it's now fixed in kdebase-3_5_2-5, which will be available in rawhide soon.
I will build new kdebase package including this fix for FC5-update soon. Thanks
for your report.

Note You need to log in before you can comment on or make changes to this bug.