Bug 1897123 - Request to rebuild qt-creator for RHEL 8.3
Summary: Request to rebuild qt-creator for RHEL 8.3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: qt-creator
Version: epel8
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Sandro Mani
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-11-12 11:39 UTC by Jens Kretschmer
Modified: 2021-06-17 15:44 UTC (History)
12 users (show)

Fixed In Version: qt-creator-4.12.4-4.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-19 01:10:56 UTC
Type: Bug


Attachments (Terms of Use)

Description Jens Kretschmer 2020-11-12 11:39:16 UTC
Description of problem:
Currently installing qt-creator on RHEL 8.3 requires a downgrade of 16 packages. This results in multiple error messages being printed if an update is performed.
RHEL 8.2 provides LLVM 9
RHEL 8.3 provides LLVM 10

Version-Release number of selected component (if applicable):
qt-creator-4.12.4-1.el8.x86_64

How reproducible:
always

Steps to Reproduce:
1. dnf install qt-creator

Actual results:
# dnf install qt-creator
Updating Subscription Management repositories.
Last metadata expiration check: 0:35:01 ago on Thu Nov 12 11:52:57 2020.
Dependencies resolved.
===============================================================================================================================================================================================================
 Package                                     Architecture                     Version                                                         Repository                                                  Size
===============================================================================================================================================================================================================
Installing:
 qt-creator                                  x86_64                           4.12.4-1.el8                                                    epel                                                        24 M
Installing dependencies:
 qt-creator-data                             noarch                           4.12.4-1.el8                                                    epel                                                       1.7 M
Downgrading:
 clang                                       x86_64                           9.0.1-2.module+el8.2.0+5494+7b8075cf                            rhel-8-for-x86_64-appstream-rpms                           360 k
 clang-devel                                 x86_64                           9.0.1-2.module+el8.2.0+5494+7b8075cf                            rhel-8-for-x86_64-appstream-rpms                           1.9 M
 clang-libs                                  x86_64                           9.0.1-2.module+el8.2.0+5494+7b8075cf                            rhel-8-for-x86_64-appstream-rpms                            31 M
 clang-tools-extra                           x86_64                           9.0.1-2.module+el8.2.0+5494+7b8075cf                            rhel-8-for-x86_64-appstream-rpms                           568 k
 libomp-devel                                x86_64                           9.0.1-1.module+el8.2.0+5384+b1459bb7                            rhel-8-for-x86_64-appstream-rpms                            18 k
 lld                                         x86_64                           9.0.1-1.module+el8.2.0+5384+b1459bb7                            rhel-8-for-x86_64-appstream-rpms                            18 k
 lld-libs                                    x86_64                           9.0.1-1.module+el8.2.0+5384+b1459bb7                            rhel-8-for-x86_64-appstream-rpms                           1.4 M
 lldb                                        x86_64                           9.0.1-2.module+el8.2.0+5384+b1459bb7                            rhel-8-for-x86_64-appstream-rpms                           5.3 M
 llvm                                        x86_64                           9.0.1-5.module+el8.2.0+6779+3ab48a6e                            rhel-8-for-x86_64-appstream-rpms                           4.2 M
 llvm-devel                                  x86_64                           9.0.1-5.module+el8.2.0+6779+3ab48a6e                            rhel-8-for-x86_64-appstream-rpms                           2.9 M
 llvm-libs                                   x86_64                           9.0.1-5.module+el8.2.0+6779+3ab48a6e                            rhel-8-for-x86_64-appstream-rpms                            19 M
 llvm-toolset                                x86_64                           9.0.1-1.module+el8.2.0+5385+5caa90f8                            rhel-8-for-x86_64-appstream-rpms                           9.7 k
 mesa-dri-drivers                            x86_64                           19.3.4-2.el8                                                    rhel-8-for-x86_64-appstream-rpms                           8.1 M
 mesa-filesystem                             x86_64                           19.3.4-2.el8                                                    rhel-8-for-x86_64-appstream-rpms                            33 k
 mesa-libxatracker                           x86_64                           19.3.4-2.el8                                                    rhel-8-for-x86_64-appstream-rpms                           1.6 M
 python3-lldb                                x86_64                           9.0.1-2.module+el8.2.0+5384+b1459bb7                            rhel-8-for-x86_64-appstream-rpms                           220 k

Transaction Summary
===============================================================================================================================================================================================================
Install     2 Packages
Downgrade  16 Packages

Total download size: 102 M
Is this ok [y/N]:

Expected results:
installing qt-creator does not require a downgrade of packages.

Additional info:

Comment 1 Sandro Mani 2020-11-12 11:55:50 UTC
I'll do so.

(qt-creator really needs a maintainer for the epel8 branch who actually uses it.)

Comment 2 Thomas Zimmermann 2020-12-16 09:20:49 UTC
qt-creator needs a rebuild for every Qt update, because it uses private headers which change even in minor updates.

I tried to rebuild it locally, so that I can continue using it.
But rebuilding doesn't work due to missing clang and llvm libs.
clang seems to have removed several shared libs in version 10, which qt-creator wants to link.

QtCreator Changelog shows the following entry for 4.13.0:
* Updated to LLVM 10

Therefore I think an update to at least this version is required.

Comment 3 Marco Vimercati 2021-01-21 10:16:59 UTC
Meanwhile is there any way to downgrade llvm/clang to make current qt-creator package working?

Comment 4 Sandro Mani 2021-01-21 10:18:43 UTC
I've fired off another rebuild. Again, qt-creator really needs a maintainer for the epel8 branch who actually uses it.

Comment 5 Fedora Update System 2021-01-21 12:05:23 UTC
FEDORA-EPEL-2021-29750af0b4 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-29750af0b4

Comment 6 Thomas Zimmermann 2021-01-21 12:33:58 UTC
I can confirm that the new build is working correctly.
Thank you.

Comment 7 Marco Vimercati 2021-01-21 14:33:16 UTC
Manually installed on CentOS 8.3, seems working well.
Thank you!

Comment 8 Fedora Update System 2021-01-22 01:45:04 UTC
FEDORA-EPEL-2021-29750af0b4 has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-29750af0b4

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Tom Hirst 2021-02-02 16:13:34 UTC
Hi Sandro,

This appears to have broken again with the update to LLVM 11, can you kick off another rebuild. Is there a guide somewhere on what I would need to do to become a maintainer for this?

Thanks

Comment 10 Sandro Mani 2021-02-02 16:48:34 UTC
Hi Tom

I've kicked off another rebuild [1]. This unfortunately will keep on happening, as I assume llvm/clang are in the EL core repos, whereas qt-creator is in EPEL, so unless whoever updates llvm/clang in EL is aware about the existence of qt-creator in EPEL and rebuilds it in sync, it will only get picked up when broken dependencies are reported.

The process for becoming a maintainer is https://fedoraproject.org/wiki/Join_the_package_collection_maintainers. I'm not a sponsor myself, but I can answer questions on the packaging process.

Sandro

[1] https://koji.fedoraproject.org/koji/taskinfo?taskID=61136945

Comment 11 Tom Hirst 2021-02-02 17:27:13 UTC
Hi Sandro,

Thanks for that, unfortunately that hasn't fixed it for the case I was trying which is installing on CentOS Stream, I guess because stream is now shipping llvm 11 and rhel 8 is still on llvm 10. Is there any plan for handling ABI differences between CentOS stream & RHEL yet?

Comment 12 Fedora Update System 2021-02-03 09:10:15 UTC
FEDORA-EPEL-2021-ab7ebd8b03 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-ab7ebd8b03

Comment 13 Sandro Mani 2021-02-03 09:11:53 UTC
> Is there any plan for handling ABI differences between CentOS stream & RHEL yet?

Uh I have no idea about that sorry, I'm just an external Fedora contributor.

Comment 14 Fedora Update System 2021-02-04 02:17:54 UTC
FEDORA-EPEL-2021-ab7ebd8b03 has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-ab7ebd8b03

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 15 Fedora Update System 2021-02-19 01:10:56 UTC
FEDORA-EPEL-2021-ab7ebd8b03 has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 16 Augustin Cavalier 2021-06-17 15:44:08 UTC
There is now the same problem once again, as 8.4 ships with LLVM 11. Can someone trigger another rebuild, please?


Note You need to log in before you can comment on or make changes to this bug.