Bug 189714 - Too old version of rpmbuild on buildsys (master?)
Too old version of rpmbuild on buildsys (master?)
Status: CLOSED RAWHIDE
Product: Fedora Infrastructure
Classification: Retired
Component: extras buildsys (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-23 14:19 EDT by Ville Skyttä
Modified: 2007-04-18 13:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-26 04:56:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2006-04-23 14:19:03 EDT
The version of rpmbuild that runs on buildsys when creating the initial srpm is
too old; it doesn't grok for example %bcond_with(out), which were introduced in
rpm 4.4.

Error: could not make srpm for xemacs-21_5_26-4_fc6 - output was:

error: line 7: Unknown tag: %bcond_with     gtk
error: query of specfile xemacs.spec failed, can't parse
error: line 7: Unknown tag: %bcond_with     gtk
error: query of specfile xemacs.spec failed, can't parse
Downloading xemacs-21.5.26.tar.gz...
--14:05:46-- 
http://cvs.fedora.redhat.com/repo/extras/xemacs/xemacs-21.5.26.tar.gz/e0cd4521e8857a16f6cd675bb4c1039b/xemacs-21.5.26.tar.gz
           => `xemacs-21.5.26.tar.gz'
Resolving cvs.fedora.redhat.com... 209.132.176.51
Connecting to cvs.fedora.redhat.com|209.132.176.51|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 15,005,618 (14M) [application/x-gzip]
14650K ...                                                   100%   14.91 MB/s
14:06:10 (616.28 KB/s) - `xemacs-21.5.26.tar.gz' saved [15005618/15005618]
FINISHED --14:06:10--
Downloaded: 15,005,618 bytes in 1 files
-rw-rw-rw-  1 root root 15005618 Apr  6 02:47 xemacs-21.5.26.tar.gz
rpmbuild --define "_sourcedir
/tmp/8131-xemacs-21_5_26-4_fc6-1145815542/xemacs/devel" --define "_builddir
/tmp/8131-xemacs-21_5_26-4_fc6-1145815542/xemacs/devel" --define "_srcrpmdir
/tmp/8131-xemacs-21_5_26-4_fc6-1145815542/xemacs/devel" --define "_rpmdir
/tmp/8131-xemacs-21_5_26-4_fc6-1145815542/xemacs/devel" --define "dist .fc6"
--define "fedora 6" --nodeps -bs xemacs.spec
error: line 7: Unknown tag: %bcond_with     gtk
make: *** [srpm] Error 1
Comment 1 Ville Skyttä 2006-04-23 14:33:34 EDT
Forgot to note that this problem didn't exist last week.
Comment 2 Jeremy Katz 2006-04-24 13:25:51 EDT
Seth -- is this related to the reinstall on extras64?
Comment 3 Seth Vidal 2006-04-24 13:59:08 EDT
we reinstalled onto rhel4.

rpm -q rpm-build
rpm-build-4.3.3-13_nonptl

is that one too old?
Comment 4 Ville Skyttä 2006-04-24 14:19:17 EDT
It is too old for specfiles taking advantage of rpm >= 4.4 only features, which
are ok per se for packages targeting >= F[CE]4.

IMO the long term fix should be to invoke all rpmbuild operations, including the
initial "make srpm", in the environment to which the package is targeted at. 
But implementing that will probably take a bit of time and effort so it could be
a good idea to look for a workaround, for example by installing a recent version
of rpmbuild for these purposes in the master server or upgrading its system one.
Comment 5 Seth Vidal 2006-04-25 00:58:23 EDT
I can build the fc4 rpm for rhel4 and see how much other shit breaks.

Anyone else already have one?
Comment 6 Axel Thimm 2006-04-25 04:28:08 EDT
ATrpms uses rpm 4.4 with RHEL4 since April 2005, e.g. a year now, and nothing
broke, so it should be safe.

But why use non-FC hosts for FC related builds at all? Wouldn't it make sense to
have Fedora builds self-hosted? Speaking from the marketing POV, not
technically. Technically you could probably build in chroots on an Ubuntu host
as well ;)
Comment 7 Seth Vidal 2006-04-25 16:33:36 EDT
Try it again:

rpm -q rpm-build
rpm-build-4.4.1-21.centos4

I think that version should cut the proverbial mustard.

Thanks to Paul for the hint about killing the fc4-specific selinux patch

If it works - please close the bug.
Comment 8 Ville Skyttä 2006-04-26 04:56:33 EDT
Yep, it worked.

Note You need to log in before you can comment on or make changes to this bug.