Bug 189733 - Cannot chroot from FC5 installer (linux rescue) on i586
Cannot chroot from FC5 installer (linux rescue) on i586
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-23 22:24 EDT by Simon Roberts
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-24 05:06:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Roberts 2006-04-23 22:24:53 EDT
Description of problem:
Complete FC5 system has been installed on an i686 computer, and the hard-drive
has been moved to a VIA C3 800A system (known issue - system does not boot due
to i686 kernel/glibc).  Booted off the FC5 install DVD, selected "linux rescue",
and attempted to chroot to /mnt/sysimage to fix the problem.  System responded
with an "illegal instruction" error.  Is something in that chroot binary (or
glibc?) using i686-only instructions?

Version-Release number of selected component (if applicable):
FC5 install DVD, as released.

How reproducible:
Every time.

Steps to Reproduce:
1. Install FC5 on i686 machine                - may not be related
2. Move disk to i586 machine (VIA C3 800A)    - may not be related
3. Boot from FC5 install DVD, select "linux rescue"
4. Enter "chroot /mnt/sysimage/".  
  
Actual results:
System responds with "illegal instruction"

Expected results:
Chroot to installed filesystem root.

Additional info:
The C3 is *almost* i686, it's just missing an instruction or two, AFAIK. There
was a related issue around FC2-3, requiring use of c3boot.iso etc.
Comment 1 Jakub Jelinek 2006-04-24 05:06:54 EDT
Not in the chroot binary, but if you have glibc*.i686.rpm installed, then
obviously the installed C library has many i686+ instructions.
You need to reinstall *.i386.rpm glibc (and other packages you have installed
in *.i686.rpm versions, I think e.g. openssl is) first, on your i686 box, then
you should be able to chroot just fine.  But that's not a bug in the packages,
just user error.

Note You need to log in before you can comment on or make changes to this bug.