Bug 189740 - Cannot install jms or jta using up2date
Summary: Cannot install jms or jta using up2date
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Pradeep Kilambi
QA Contact: Brandon Perkins
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-04-24 07:58 UTC by Stuart Campbell
Modified: 2018-10-19 23:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-19 18:07:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stuart Campbell 2006-04-24 07:58:25 UTC
Description of problem:

I cannot seem to install the package jms (and therefore any packages that rely
on it) using up2date.  I'm not sure if this bug should be filed under up2date,
RHN or Application server so apologies if this is the wrong one.


Version-Release number of selected component (if applicable):
up2date-4.4.67-4
rhnlib-1.8.2-1.p23.1

How reproducible:

everytime

Steps to Reproduce:
1. Register machine with RHN
2. Subscribe to Red Hat Application Server Channel
3. type up2date jms
  
Actual results:

[root@pc013 home]# up2date jms

Fetching Obsoletes list for channel: rhel-i386-as-4...

Fetching Obsoletes list for channel: rhel-i386-as-4-extras...

Fetching Obsoletes list for channel: rhn-tools-rhel-4-as-i386...

Fetching Obsoletes list for channel: rhel-4-as-i386-rhaps-2...

Fetching rpm headers...
########################################

Name                                    Version        Rel
----------------------------------------------------------
jms                                     1.1            3jpp_2rh          noarch

Testing package set / solving RPM inter-dependencies...
########################################

The following packages you requested are already updated:
jms

[root@pc013 home]# rpm -q jms
package jms is not installed

Expected results:

To install jms

Additional info:

Comment 1 Stuart Campbell 2006-04-24 08:31:20 UTC
This also happens with the jta package.

Comment 2 Red Hat Bugzilla 2007-04-12 00:39:34 UTC
User bnackash@redhat.com's account has been closed

Comment 3 Chris Williams 2007-07-11 18:17:33 UTC
rpm --test works just fine on the RPM:

[root@pvrhel45 tmp]# ls | grep jta
jta-1.0.1-0.b.3jpp_2rh.noarch.rpm
[root@pvrhel45 tmp]# rpm -Uvh --test jta-1.0.1-0.b.3jpp_2rh.noarch.rpm
Preparing...                ########################################### [100%]

But an up2date does not:

[root@pvrhel45 tmp]# up2date -v jta

Fetching Obsoletes list for channel: rhel-i386-as-4...

Fetching Obsoletes list for channel: rhel-i386-as-4-extras...

Fetching Obsoletes list for channel: rhel-4-as-i386-rhaps-2...

Fetching rpm headers...
########################################

Name                                    Version        Rel     
----------------------------------------------------------
jta                                     1.0.1          0.b.3jpp_2rh      noarch
No advisory information available



Testing package set / solving RPM inter-dependencies...
########################################
There was a fatal RPM error. The message was:
Failed running rpm transaction

Comment 7 Fernando Nasser 2007-09-19 16:26:31 UTC
jms is an obsolete package.  Please use geronimo-jms-1.1-api instead.
Attempts to install an obsoleted package with up2date will fail because of the
"Obsoletes" that is in geronimo-jms-1.1-api.

Hope that helps.

Comment 12 RHEL Product and Program Management 2007-11-29 04:26:07 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.


Note You need to log in before you can comment on or make changes to this bug.