Bug 189745 - Spell check failed after upgrade to kdelibs-3.5.2-0.1.fc4
Spell check failed after upgrade to kdelibs-3.5.2-0.1.fc4
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: aspell (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-24 05:30 EDT by Frank Wang
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: aspell-0.60.3-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-16 06:13:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Wang 2006-04-24 05:30:50 EDT
Description of problem:
Spell check in kmail failed with "ISpell/Aspell could not be started. Please 
make sure you have ISpell or Aspell properly configured and in your PATH." Yet 
it works flawlessly before kde upgrade. Similar errors reported by other apps 
in kde, like kate, if spell check used.

Version-Release number of selected component (if applicable):
kdelibs-3.5.2-0.1.fc4

How reproducible:
Always

Steps to Reproduce:
1.Start kmail
2.Reply any mail
3.Choose Tools -> Spelling...
  
Actual results:
"ISpell/Aspell could not be started. Please make sure you have ISpell or 
Aspell properly configured and in your PATH." reported

Expected results:
Spell check the mail while typing

Additional info:
Comment 1 Ngo Than 2006-05-08 14:08:52 EDT
It seems aspell is not installed on your machine. Could you please check if
/usr/bin/aspell does exist?



Comment 2 Frank Wang 2006-05-09 02:33:19 EDT
(In reply to comment #1)
> It seems aspell is not installed on your machine. Could you please check if
> /usr/bin/aspell does exist?
> 
It's still there.
[frank@twinhead tmp]$ which aspell
/usr/bin/aspell
[frank@twinhead tmp]$ rpm -q aspell
aspell-0.50.5-6
[frank@twinhead tmp]$ echo $PATH
/usr/kerberos/bin:/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin:/usr/local/jdk1.5.0/bin:/usr/local/jdk1.5.0/jre/bin:/home/frank/bin
Comment 3 Ngo Than 2006-05-09 10:22:27 EDT
it's strange! i cannot reproduce this problem here. Does the problem still appear
with a new user? Could you please try to reinstall aspell package (rpm -ivh
--force) and try again? thanks
Comment 4 Frank Wang 2006-05-10 06:38:41 EDT
    I'm sure the package is there. Still, I followd your advice to download 
the aspell pkg and forcefully install it. It's the same. Choose other user 
doesn't help either. Further test shows that it's probably related with 
language setting:
[root@twinhead tmp]# echo "something wrogn " | aspell list
Error: No word lists can be found for the language "zh_CN".
[root@twinhead tmp]# echo $LANG
zh_CN.UTF-8
[root@twinhead tmp]# echo "something wrogn " | aspell --lang=en_US list
wrogn

   I tried to config aspell to use an en dictionary in control center -> spell 
checker -> Dictionary but there is only one "ASpell default" option. Tweaking 
other settings there doesn't help. Maybe set the LANG to en_US.UTF8 system 
wide is a workaround but I still like to keep my current locale since I 
primarily use Chinese as my default language.
Comment 5 Ngo Than 2006-05-10 12:10:01 EDT
It's a bug in aspell. The dictionaries are installed in /usr/lib/aspell but 
"pspell-config --pkgdatadir" tells in /usr/share/aspell.

kdelibs uses "pspell-config --pkgdatadir" to look for the dictionnary and in 
this case only in /usr/share/aspell.

aspell should install the dictionnaries in /usr/share/aspell

This problem does not happen in FC5 with aspell-0.60
Comment 6 Frank Wang 2006-05-10 22:15:35 EDT
Thanks for you info.
I tried to sym link all files in /usr/lib/aspell to /usr/share/aspell, but 
aspell insist 'No word lists can be found for the language "zh_CN"'. Anyway, 
I've temporarily altered the LANG to en_US.UTF8 before I have chance to 
upgrade to fc5. 
Thanks again!
Comment 7 Ngo Than 2006-05-11 07:38:46 EDT
you have to config aspell to use an en dictionary in control center -> spell
checker -> Dictionary
Comment 8 Frank Wang 2006-05-11 10:14:04 EDT
(In reply to comment #7)
> you have to config aspell to use an en dictionary in control center -> spell
> checker -> Dictionary

As I said, there is only a "ASpell default" option there. No other 
dictionaries can be chosen.
Comment 9 Ngo Than 2006-05-15 10:54:15 EDT
Have you to restarted KDE after doing symlinks? It't needed!
Comment 10 Frank Wang 2006-05-16 01:53:24 EDT
You're right, forgot to restart KDE then. I sym link all files 
from /usr/lib/aspell to /usr/share/aspell and restart X this time, and aspell 
works with dictionary English and encoding UTF8.
Thanks!
Comment 11 Ivana Varekova 2006-05-16 06:13:00 EDT
This problem is fixed in fc5 - aspell dictationaries and data files are in
/usr/lib/aspell-0.60. 
pspell-config --pkgdatadir
 return the directory where data files of aspell dictationaries are - not the
directory where dictationary files are, from aspell-0.60 all files are in the
same directory. 

Note You need to log in before you can comment on or make changes to this bug.