Bug 189756 - dia: shouldn't own %_datadir/applications
dia: shouldn't own %_datadir/applications
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: dia (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
: EasyFix, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-24 09:05 EDT by Rex Dieter
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-25 15:55:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2006-04-24 09:05:08 EDT
dia (or any desktop app) shouldn't own %_datadir}/applications.  %files should
instead include:
%{_datadir}/applications/*.desktop
Comment 1 Rex Dieter 2006-04-24 09:06:45 EDT
Another small comment, why include in the .specfile:
----------------
# remove scrollkeeper stuff we don't include in the package
rm -rf $RPM_BUILD_ROOT/var
----------------

But then call scrollkeeper-update in %%post/%%postun?
Comment 2 Hans de Goede 2006-04-25 07:23:29 EDT
Thanks!

The desktop file wasn't installed correctly either, nor were the icons. This
happens with package which come from Core :|

About:
# remove scrollkeeper stuff we don't include in the package
rm -rf $RPM_BUILD_ROOT/var

dia doesn't use scrollkeeper at all, so I've removed both these 2 lines and the
scrollkeeper-update calls and requirements.

I'll commit 0.95-0.pre9.1 soon and build it.
Comment 3 Hans de Goede 2006-04-25 07:24:40 EDT
Darn,

My build just failed with unpackaged files under /var/scrollkeeper, I thought
rpm checked for that earlier in the build then this. A well.
Comment 4 Rex Dieter 2006-04-25 08:12:39 EDT
Hasn't dia-0.9.5(final) been released as well?  :)
Comment 5 Hans de Goede 2006-04-25 15:55:14 EDT
(In reply to comment #4)
> Hasn't dia-0.9.5(final) been released as well?  :)

You're right 0.95 final has been released, thanks.

About the scrollkeeper stuff it seems that dia does generate some scrollkeepr
stuff under /var/lib/scrollkeeper during %install, but thats obsolete and it
doesn't add any omf descriptions to /usr/share/omf, so I've dropped the
scrollkeeper-update stuff and kept the
rm -fr $RMP_BUILD_ROOT/var/lib/scrollkeeper

0.95 is building on the buildsys for devel as I type. Since 0.95 is final now
and 0.94 has issue I'll push 0.95 to FC-5 too.

Note You need to log in before you can comment on or make changes to this bug.