Bug 189772 - ftp client: runique on stops mget from working
ftp client: runique on stops mget from working
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: ftp (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
Ben Levenson
:
Depends On:
Blocks: 187539
  Show dependency treegraph
 
Reported: 2006-04-24 11:18 EDT by Miroslav Lichvar
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: RHBA-2006-0409
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-10 17:36:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Lichvar 2006-04-24 11:18:05 EDT
+++ This bug was initially created as a clone of Bug #79367 +++

Description of Problem:

The ftp client does not support the combination of 'runique' and 
'mget' as stated in the man pages.  If runique is turned on during an ftp
session, 'mget' fails to get 
anything.  However, 'get' will get the file and rename it with a ".1" (or
appropriate 
number).

Version-Release number of selected component (if applicable):
Not sure, 
whatever comes with RedHat 7.1 and 7.3 by default

How Reproducible:
Consistent

Steps 
to Reproduce:
1. FTP to a site with some files to get
2. Turn on runique (ftp> runique)
3. 
Attempt to do an mget (ftp> mget *)
4. No files will be transferred.
5. Turn runique off (ftp> 
runique)
6. Attempt to do an mget (ftp> mget *)
7. All matching files will be transferred
8. 
Turn runique off again
8. Try 'get' and it will get the specified file (ftp> get filename)
9. 
Try 'get' again and it will get the file and rename it with a .1 (ftp> get filename)

Actual 
Results:
Mget does not transfer files with runique on but works fine with runique 
off.

Expected Results:
mget should get all the matching filenames and rename them with a 
suffix if .## (such as .1) when runique is turned on.

Additional Information:
I tried this 
in SuSE Linux 7.3 and it has the same problem.

-- Additional comment from twoerner@redhat.com on 2004-04-21 11:31 EST --
Is this /usr/bin/ftp or /usr/kerberos/bin/ftp?

-- Additional comment from donnie_cambre@stercomm.com on 2004-04-21 11:33 EST --
This is /usr/bin/ftp

-- Additional comment from twoerner@redhat.com on 2004-10-07 10:04 EST --
Please verify this with a newer version of Red Hat Enterprise Linux or
Fedora Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.


-- Additional comment from donnie_cambre@stercomm.com on 2004-10-14 13:36 EST --
Tested with the same result in RedHat Enterprise Linux Advanced Server
2.1.  If runique is enabled, mget does not function.

-- Additional comment from twoerner@redhat.com on 2004-12-07 06:38 EST --
Please have a look at 

http://people.redhat.com/twoerner/SRPMS/2.1AS/ftp-0.17-12.1.3.src.rpm
http://people.redhat.com/twoerner/RPMS/2.1AS/ftp-0.17-12.1.3.i386.rpm

This package should fix the problem.

----
Please remeber that this is a test package, which might be pushed out as an
update package later if the fixes are ok.

-- Additional comment from donnie_cambre@stercomm.com on 2004-12-07 10:05 EST --
Tested the linked update (ftp-0.17-12.1.3.i386.rpm) on RHEL AS 2.1 and it fixes
the problem.

-- Additional comment from praszyk@redhat.com on 2005-08-22 08:02 EST --
This bug was fixed by Thomas Woerner <twoerner@redhat.com> on 2004-12-07
It is a patch netkit-ftp-0.17-runique_mget.patch.
This 'bug' does not occure in FEDOR CORE 4.
Comment 5 Red Hat Bugzilla 2006-05-10 17:36:42 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0409.html

Note You need to log in before you can comment on or make changes to this bug.