Bug 189804 - consider adding option to pirut to look at alternate yum config file
consider adding option to pirut to look at alternate yum config file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-24 16:00 EDT by Erik Jacobson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-26 14:45:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
add command line switch to pirut to support alternate yum cfg (1.39 KB, patch)
2006-04-24 16:00 EDT, Erik Jacobson
no flags Details | Diff

  None (edit)
Description Erik Jacobson 2006-04-24 16:00:14 EDT
I think it would be helpful if pirut could took a command line argument that
allows for it to look at an alternate yum configuration file for presenting
the graphical repository view.

It's possible that my reasons for wanting this might disappear with future
pirut development, but it still seems like a nice option to have around
if for no other reason than to make it easier to test things.

One thing I'm concerned about is being able to install add-on software 
from CD. 188750 exists to make this support available directly.  My options
increase with such an option as I can point pirut at the YUM repo on the CD.
Jeremy pointed out in a different bug that we could just put a temporary
repository file in to place, but read below.

Another reason I'd like this is because, as written now, if any of the
existing repositories are inaccessible, pirut fails rather than allowing
you to work with the repositories that are accessible.  Reasons for
repositories being unavailable could be network/Internet connection 
problems, incorrect proxy settings, botched config files, no outside network
(secure site), etc.  If I have an option to point at an alternate yum 
config file, I can make the stuff I want to install from CD be the only 
choices.  This lets me avoid issues with networking and/or inaccessible
repositories. 

My guess is the above problem will go away in the future when repo management
features are added in to pirut.

I'm going to attach a patch that allows pirut to look at an alternate
yum config file if one is supplied on the command line.  Do keep in mind
that I'm not a yum expert so I'd consider the patch more an illustration
than an actual thing you'd import.
Comment 1 Erik Jacobson 2006-04-24 16:00:15 EDT
Created attachment 128165 [details]
add command line switch to pirut to support alternate yum cfg
Comment 2 Erik Jacobson 2006-04-24 16:05:05 EDT
Above, where I said:
  Do keep in mind that I'm not a yum expert so I'd consider the patch more an   
  illustration than an actual thing you'd import.

I meant to say I'm not a python expert, so please look at the patch carefully
:)
Comment 3 Jeremy Katz 2006-04-26 14:45:15 EDT
Did things a little bit cleaner in CVS and will be in 1.0.3.  You'll need to run
with --config or -c instead of just passing the config file as a bare argument.

Note You need to log in before you can comment on or make changes to this bug.