Bug 189842 - i have tried to compile mythtv on 3 machines, all get the same GCC error "internal compiler error: Segmentation fault"
i have tried to compile mythtv on 3 machines, all get the same GCC error "int...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gcc4 (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-24 20:13 EDT by David Kennedy
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-09 04:30:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Kennedy 2006-04-24 20:13:08 EDT
Description of problem:
whenever i compile mythtv, it seems the c++ compiler dies


Version-Release number of selected component (if applicable):
mythtv 0.19 and mythtv subversion

How reproducible:
compile mythtv

Steps to Reproduce:
1. download mytthv source
2. configure as follows "./configure --prefix=/usr/local --enable-xvmc
--arch=i686 --enable-proc-opt --enable-dvb"
3.qmake as follows "qmake PREFIX=/usr/local mythtv.pro"
4. "make"
  
Actual results:

../../libs/libmyth/mythwidgets.h:296: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
The bug is not reproducible, so it is likely a hardware or OS problem.



Expected results:

mythtv should compile clean

Additional info:
i know its possible to compile this as people like atrpms have it done already.
 in fact, installing from those sources works.
Comment 1 Jakub Jelinek 2006-04-25 04:37:06 EDT
Is it always on the same source file, exact same error message?
The GCC message suggests it is not (in which case it is a hardware problem),
but just in case.  If it is, you need to provide preprocessed source
and exact GCC command line options used.
Comment 2 Jakub Jelinek 2006-05-09 04:30:19 EDT
No response in 14 days, closing.

Note You need to log in before you can comment on or make changes to this bug.