Bug 189855 - undefined reference to `FT_GlyphSlot_Embolden' (with workaround)
Summary: undefined reference to `FT_GlyphSlot_Embolden' (with workaround)
Alias: None
Product: Fedora
Classification: Fedora
Component: cairo
Version: 5
Hardware: i686
OS: Linux
Target Milestone: ---
Assignee: Behdad Esfahbod
QA Contact:
Whiteboard: bzcl34nup
Depends On:
TreeView+ depends on / blocked
Reported: 2006-04-25 08:51 UTC by JeeBee
Modified: 2008-05-06 15:50 UTC (History)
1 user (show)

Clone Of:
Last Closed: 2008-05-06 15:50:32 UTC

Attachments (Terms of Use)

Description JeeBee 2006-04-25 08:51:21 UTC
Description of problem:
Cannot compile several program anymore, like dbus (cvs version), kvirc (cvs
version) and my guess is all other programs that use libcairo (-lcairo in their
link flags).

Version-Release number of selected component (if applicable):
(by the way, I think I had freetype-2.1.10-5.2.1 this morning which had the same
problem, tried to fix it by upgrading freetype but that didn't change anything).

How reproducible:
I guess just compile any program that uses enough cairo functions hence must be
compiled with -lcairo. For me it's reproducible each time I tried to compile
dbus of kvirc.

Steps to Reproduce:
1. checkout dbus cvs
2. try to build it ...
Actual results:
undefined reference to `FT_GlyphSlot_Embolden'

Expected results:
You compiled successfully, have a nice day.

Additional info:
Prepending -lfreetype to -lcairo solves the issue. I guess libcairo should be
linking to libfreetype for the missing symbol right???

Comment 1 Bug Zapper 2008-04-04 02:45:05 UTC
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers

Comment 2 Bug Zapper 2008-05-06 15:50:30 UTC
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.