Bug 189861 - dhclient causes WPA authentication to be dropped
dhclient causes WPA authentication to be dropped
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Jason Vas Dias
Depends On:
  Show dependency treegraph
Reported: 2006-04-25 07:06 EDT by David Anderson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-04-25 08:08:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description David Anderson 2006-04-25 07:06:45 EDT
Description of problem:

Running dhclient on my Atheros network card causes the previously successful 
WPA authentication to fail.

Version-Release number of selected component (if applicable):
(kmod-madwifi-, wpa_supplicant-0.4.8-7.fc5)

How reproducible:
Every time. (Tried about 5 times. As soon as I stopped using dhclient and 
instead configured manually, everything worked).
Access point is a LinkSys WAP54G.

Steps to Reproduce:
1. Insert Atheros-based wireless card
2. service wpa_supplicant start (configured with key_mgmt=WPA-PSK, proto=WPA)
3. Do "/sbin/iwconfig ath0 essid MYSSID"
4. Wait for "/sbin/iwconfig ath0" to demonstrate that association has been 
5. Run "dhclient ath0".

Actual results:
dhclient obtains an IP address, updates the interface, and then immediately 
wpa_supplicant gets authentication failed and remains in that state. (This 
causes dhclient to quit, too).

However, if you don't use dhclient (i.e. configure the interface manually with 
"ifconfig" and "route" and edit /etc/resolv.conf manually), then the interface 
continues working fine. (I am currently entering this bug via the interface in 
question, having configured it manually).

I used this same setup with this same access point on Fedora Core 4 (fully 
updated) about 2 months ago, and there were no problems.

Expected results:
Everything works happily.

Additional info:
My system is fully updated.
Comment 1 David Anderson 2006-04-25 08:08:55 EDT
Sorry - bug is elsewhere. Closing.

Note You need to log in before you can comment on or make changes to this bug.