Bug 189879 - Incorrect parsing of URLs with special characters
Summary: Incorrect parsing of URLs with special characters
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: evolution   
(Show other bugs)
Version: 4.0
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 176344 229557 234251
TreeView+ depends on / blocked
 
Reported: 2006-04-25 14:18 UTC by Bastien Nocera
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-31 20:44:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gtkhtml3-try-match-url-garbage-3-rhel4.patch (946 bytes, patch)
2006-04-25 14:18 UTC, Bastien Nocera
no flags Details | Diff
Attaching Bastien's patch (note: patch applies to evolution in RHEL4, evolution-data-server in FC5) (679 bytes, patch)
2006-08-18 18:27 UTC, Brad Hinson
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 327874 None None None Never
GNOME Bugzilla 349445 None None None Never

Description Bastien Nocera 2006-04-25 14:18:53 UTC
gtkhtml3-3.3.2-6.EL

Consider the portion of mail:
 <http://mysystem/MSDOS/'SHARED.PZ00.PROD.SUPERBATCH.ZIPLIB(Z00055R)'>

The URL is actually:
http://mysystem/MSDOS/'SHARED.PZ00.PROD.SUPERBATCH.ZIPLIB(Z00055R)'
But Evolution only highlights:
http://mysystem/MSDOS/'SHARED.PZ00.PROD.SUPERBATCH.ZIPLIB(Z00055R

 From RFC 1738:
  Thus, only alphanumerics, the special characters "$-_.+!*'(),", and
  reserved characters used for their reserved purposes may be used
  unencoded within a URL.

The attached patch will rewind only if the character doesn't have a matching
one in the URL.

Similar patch is available for Gtkhtml HEAD:
http://bugzilla.gnome.org/show_bug.cgi?id=327874

Comment 1 Bastien Nocera 2006-04-25 14:18:55 UTC
Created attachment 128203 [details]
gtkhtml3-try-match-url-garbage-3-rhel4.patch

Comment 2 Bastien Nocera 2006-04-25 14:20:50 UTC
This only works for writing mails, displaying text mails still has the same problem.

Comment 7 Bastien Nocera 2006-07-31 15:22:52 UTC
The patch in comment 1 is now committed upstream.

Comment 10 Bastien Nocera 2006-08-03 15:54:53 UTC
Eeek!
In camel_url_web_end() in e-d-s/camel/camel-url-scanner.c:

        /* urls are extremely unlikely to end with any
         * punctuation, so strip any trailing
         * punctuation off. Also strip off any closing
         * braces or quotes. */
        while (inptr > pos && strchr (",.:;?!-|)}]'\"", inptr[-1]))
                inptr--;

That's obviously a wrong assumption in our case. See upstream bug for details.

Comment 12 RHEL Product and Program Management 2006-08-18 16:06:26 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 13 Matthew Barnes 2006-08-18 17:16:25 UTC
Brad, I'm not sure which patch you're referring to.  I don't see one in the
upstream bug [1].  Did you forget to post it or am I misreading something?

[1] http://bugzilla.gnome.org/show_bug.cgi?id=349445

Comment 14 Brad Hinson 2006-08-18 18:27:53 UTC
Created attachment 134463 [details]
Attaching Bastien's patch (note: patch applies to evolution in RHEL4, evolution-data-server in FC5)

Comment 15 Bastien Nocera 2006-08-21 08:41:39 UTC
Matthew, the original patch is at:
http://bugzilla.gnome.org/show_bug.cgi?id=327874

There's a second part, that I'm getting tested by the original reporter of the
bug, for the reading part of the bug. Brad posted the first half of the patch
(for the writing highlighting) in comment 13.

Comment 16 Matthew Barnes 2006-08-24 03:57:24 UTC
I applied the first patch to evolution-2.0.2-30.el4.

Comment 17 Matthew Barnes 2006-09-01 03:45:50 UTC
devel_ack -- Just waiting for the second half of this from Bastien.

Comment 20 Bastien Nocera 2006-09-11 08:53:55 UTC
Comment on attachment 134463 [details]
Attaching Bastien's patch (note: patch applies to evolution in RHEL4, evolution-data-server in FC5)

This patch isn't something we'd want to merge in, it's not acceptable upstream,
so shouldn't be acceptable for us.

Comment 22 Matthew Barnes 2006-09-11 14:24:08 UTC
Bastien, neither of the "GNOME Desktop" bug reports (listed below) reflect this.
 What was the problem with the patch?

Comment 23 Bastien Nocera 2006-09-11 14:39:03 UTC
I had those conversations on IRC with the Evolution guys, and Andrea Klapper,
one of their bugmasters. The patch I posted was for testing only (ie. is this
really there that the problem is?), and the solution we'd integrate should be
more solid than the current patch.

Comment 24 Bastien Nocera 2006-09-13 13:57:34 UTC
I'm pretty happy with the patch at:
http://bugzilla.gnome.org/show_bug.cgi?id=349445#c7

Hopefully I'll get some feedback soon.

Comment 33 Matthew Barnes 2006-10-25 19:53:14 UTC
No update yet, I spent most of the day drilling into bug #199751.

Comment 40 Bastien Nocera 2006-11-21 17:34:01 UTC
The patch has now been committed upstream.

Comment 46 Matthew Barnes 2006-12-07 15:42:34 UTC
evolution-2.8.0-33.el4 contains Bastien's patch at [1].

[1] http://bugzilla.gnome.org/show_bug.cgi?id=349445#c7

Comment 48 Matthew Barnes 2006-12-07 16:40:45 UTC
Oops, yeah.  As much as I'd like to rebase Evolution in RHEL-4, I'm afraid I
meant evolution-2.0.2-33.el4.  :)

Comment 72 RHEL Product and Program Management 2007-05-09 10:32:44 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 75 Matthew Barnes 2007-07-31 20:44:50 UTC
We believe this bug will be fixed in the Evolution 2.8 upgrade option scheduled
for RHEL 4.6.  Please feel free to reopen this bug report if the problem still
exists in Evolution 2.8.


Note You need to log in before you can comment on or make changes to this bug.