Bug 189950 - Package does not match kernel.
Package does not match kernel.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lksctp-tools (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-25 22:06 EDT by Ralph Loader
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.0.6-1.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-05 20:39:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralph Loader 2006-04-25 22:06:30 EDT
The lksctp-1.0.5-1.fc5.2 package in Fedora Core 5 does not match the kernel. 
(The kernel appears to implement a more recent version of the API).

E.g., in kernel-2.6.16, the sctp_paddrparams struct has more fields than the
lksctp headers, which means that applications using that fail.

[I don't believe that the kernel sctp implementation has backwards compatibility
code.]
Comment 1 Fedora Update System 2006-08-01 14:37:46 EDT
lksctp-tools-1.0.6-1.fc5 packages have been pushed for Fedora Core 5 which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 2 Ralph Loader 2006-08-01 20:30:05 EDT
lksctp-tools-1.0.6-1.fc5 fixes the problem for me.

Thanks.
Comment 3 Fedora Update System 2006-08-02 11:02:26 EDT
lksctp-tools-1.0.6-1.fc5 packages have been pushed for Fedora Core 5 which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 4 Ralph Loader 2006-11-05 20:39:12 EST
Package has been updated in FC6.

Note You need to log in before you can comment on or make changes to this bug.