Bug 189955 - Invalid UTF-8 characters in contacts crashes evolution-data-server
Invalid UTF-8 characters in contacts crashes evolution-data-server
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-25 23:06 EDT by Dean Brettle
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: evolution-data-server-1.8.2-1.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-01 16:51:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 335961 None None None Never

  None (edit)
Description Dean Brettle 2006-04-25 23:06:06 EDT
Description of problem:

After upgrading from FC3 to FC5, evolution-data-server would always crash on
startup and many of my contacts were not displayed.  Also, any attempt to search
 my contacts caused evolution to hang.

Searching the upstream bugs, I found:

http://bugzilla.gnome.org/show_bug.cgi?id=335961

The workaround described in that bug fixed the problem for me, so it looks like
the problem was caused by invalid UTF-8 in some of my contacts.

It would be nice to get the fix attached to that bug into a future FC5 update.
Comment 1 Marc Schwartz 2006-06-01 09:11:34 EDT
FWIW, I can confirm both the bug and the fix in Comment #19 in the GNOME bug
report on FC5 with:

$ rpm -qa | grep evolution
evolution-connector-2.6.1-1.fc5.1
evolution-sharp-0.10.2-9
evolution-data-server-devel-1.6.1-1.fc5.2
evolution-data-server-1.6.1-1.fc5.2
evolution-webcal-2.4.1-3.2
evolution-2.6.1-1.fc5.2

This was a clean install of FC5 from FC4, not an upgrade. The contact list
worked without issue on FC4.
Comment 2 Matthew Barnes 2007-01-01 16:51:07 EST
Apologies for taking so long to respond.

According to the upstream bug referenced in comment #0, the problem was
reportedly fixed in an update to evolution-data-server-1.6.x.  Feel free to
re-open this bug if the problem is still present in Fedora Core 6.

Note You need to log in before you can comment on or make changes to this bug.