Bug 189958 - libgnome-2.14.1-1.fc5.1 conflicts with libgnome-2.10.0-3 (yum update)
libgnome-2.14.1-1.fc5.1 conflicts with libgnome-2.10.0-3 (yum update)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: libgnome (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-26 03:20 EDT by Gael Fraiteur
Modified: 2008-03-18 14:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-18 14:33:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gael Fraiteur 2006-04-26 03:20:10 EDT
Description of problem:
Cannot install: libgnome-2.14.1-1.fc5.1 conflicts with lib           gnome-2.10.0-3

Version-Release number of selected component (if applicable):
libgnome-2.14.1-1.fc5.1 (on x86_64)

How reproducible:
always during yum update

Steps to Reproduce:
1. yum update libgnome
  
Actual results:

Transaction Check Error:   file
/etc/gconf/schemas/desktop_gnome_accessibility_keyboard.schemas from install of
libgnome-2.14.1-1.fc5.1 conflicts with file from package libgnome-2.10.0-3
  file /etc/gconf/schemas/desktop_gnome_accessibility_startup.schemas from
install of libgnome-2.14.1-1.fc5.1 conflicts with file from package
libgnome-2.10.0-3
  file /etc/gconf/schemas/desktop_gnome_applications_browser.schemas from
install of libgnome-2.14.1-1.fc5.1 conflicts with file from package
libgnome-2.10.0-3
  file /etc/gconf/schemas/desktop_gnome_applications_help_viewer.schemas from
install of libgnome-2.14.1-1.fc5.1 conflicts with file from package
libgnome-2.10.0-3
  file /etc/gconf/schemas/desktop_gnome_applications_terminal.schemas from
install of libgnome-2.14.1-1.fc5.1 conflicts with file from package
libgnome-2.10.0-3
  file /etc/gconf/schemas/desktop_gnome_applications_window_manager.schemas from
install of libgnome-2.14.1-1.fc5.1 conflicts with file from package
libgnome-2.10.0-3
  file /etc/gconf/schemas/desktop_gnome_background.schemas from install of
libgnome-2.14.1-1.fc5.1 conflicts with file from package libgnome-2.10.0-3
  file /etc/gconf/schemas/desktop_gnome_file_views.schemas from install of
libgnome-2.14.1-1.fc5.1 conflicts with file from package libgnome-2.10.0-3
  file /etc/gconf/schemas/desktop_gnome_interface.schemas from install of
libgnome-2.14.1-1.fc5.1 conflicts with file from package libgnome-2.10.0-3
  file /etc/gconf/schemas/desktop_gnome_lockdown.schemas from install of
libgnome-2.14.1-1.fc5.1 conflicts with file from package libgnome-2.10.0-3
  file /etc/gconf/schemas/desktop_gnome_peripherals_keyboard.schemas from
install of libgnome-2.14.1-1.fc5.1 conflicts with file from package
libgnome-2.10.0-3
  file /etc/gconf/schemas/desktop_gnome_peripherals_mouse.schemas from install
of libgnome-2.14.1-1.fc5.1 conflicts with file from package libgnome-2.10.0-3
  file /etc/gconf/schemas/desktop_gnome_sound.schemas from install of
libgnome-2.14.1-1.fc5.1 conflicts with file from package libgnome-2.10.0-3
  file /etc/gconf/schemas/desktop_gnome_thumbnailers.schemas from install of
libgnome-2.14.1-1.fc5.1 conflicts with file from package libgnome-2.10.0-3
  file /etc/gconf/schemas/desktop_gnome_typing_break.schemas from install of
libgnome-2.14.1-1.fc5.1 conflicts with file from package libgnome-2.10.0-3
  file /etc/sound/events/gnome-2.soundlist from install of
libgnome-2.14.1-1.fc5.1 conflicts with file from package libgnome-2.10.0-3
  file /etc/sound/events/gtk-events-2.soundlist from install of
libgnome-2.14.1-1.fc5.1 conflicts with file from package libgnome-2.10.0-3


Expected results:
sucess

Additional info:
Comment 1 Eugen Leitl 2006-07-14 05:22:06 EDT
This is a nasty problem, if I am to remove the 32 bit version of libgnome,
I'd lose the following software:

Removing:
 libgnome                i386       2.14.0-1         installed         3.1 M
Removing for dependencies:
 R                       x86_64     2.3.1-1.fc5      installed          44 M
 R-devel                 x86_64     2.3.1-1.fc5      installed         700 k
 R-gnomeGUI              x86_64     2.1.0-5.fc5      installed         118 k
 R-mAr                   x86_64     1.1-5.fc5        installed         177 k
 R-waveslim              x86_64     1.5-3.fc5        installed         2.7 M
 R-wavethresh            x86_64     2.2-3.fc5        installed         465 k
 firefox                 i386       1.5.0.1-9        installed          35 M
 libbonoboui             i386       2.14.0-1         installed         1.2 M
 libgnomeui              i386       2.14.0-1         installed         3.1 M
 moodss                  x86_64     21.2-1.fc5       installed         5.5 M
 moomps                  noarch     5.6-1.fc5        installed         1.2 M
 rpy                     x86_64     0.4.6-11.fc5     installed         393 k


I have to run 32 bit firefox, so upgrading to 64 bit Firefox is not an option.
Temporary removing firefox for upgrade would kill sessionsaver state and many
extensions.
Comment 2 Chris Petersen 2006-12-16 23:13:45 EST
I believe that this is actually a bug with yum, not libgnome.  On the off chance
that it isn't, and since I couldn't change the target for this bug, I've opened
bug 219935.
Comment 3 Ray Strode [halfline] 2008-03-18 14:33:35 EDT
Hi,

We no longer support Fedora Core 5 and I am currently trying to get my open bug
count down to a more manageable state.  I'm going to close this bug as WONTFIX.
 If this issue is still a concern for you, would you mind trying to reproduce on
a supported version of Fedora and reopening?

(this is a mass message)

Note You need to log in before you can comment on or make changes to this bug.