Bug 189984 - python bindings ignore skeleton=... setting
Summary: python bindings ignore skeleton=... setting
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libuser   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Miloslav Trmač
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-04-26 14:24 UTC by Chris Lumens
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 0.54.6-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-01 05:29:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Lumens 2006-04-26 14:24:51 UTC
The libuser python binding for addUser appears to ignore the skeleton= setting
in libuser.conf.  In addition, createHome supports a keyword argument for
setting it, but addUser doesn't provide any way to pass this argument to
createHome.  Looks like the only way to do it is to call addUser with
mkhomedir=0/False/whatever, then call createHome yourself afterwards.

Please check that mkmailspool also behaves sensibly in addUser.

Comment 1 Miloslav Trmač 2006-05-01 05:29:11 UTC
Should be fixed in rawhide libuser-0.54.6: Both admin methods default to
[defaults]/skeleton, and both allow overriding using the "skeleton=" keyword
parameter.

Thanks for your report.


Note You need to log in before you can comment on or make changes to this bug.