Bug 189988 - tg3 driver v3.43-rh in kernel 2.6.9-34.EL fails to initialize first VLAN interface
tg3 driver v3.43-rh in kernel 2.6.9-34.EL fails to initialize first VLAN inte...
Status: CLOSED DUPLICATE of bug 188087
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-26 10:40 EDT by Steve Snodgrass
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-26 12:52:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Snodgrass 2006-04-26 10:40:21 EDT
Description of problem: I have a RHEL4 system (Dell 2650) that uses an 802.1q
VLAN trunk to connect to multiple subnets.  This has worked fine for some time,
but upon upgrading to kernel 2.6.9-34.EL one of the VLAN interfaces stopped
working.  The interface works fine if I boot back to 2.6.9-22.0.1.EL.  After
some experimentation I found that whichever VLAN interface is brought up first
fails to work; the others are fine.  The network port is Tigon3
[partno(BCM95703A30) rev 1002 PHY(5703)].  I believe the updated tg3 driver
(v3.43-rh) in this kernel is the culprit, because I have a Dell 2850 with e1000
interfaces in a very similar configuration and the VLAN interfaces work fine on
2.6.9-34.EL.

Version-Release number of selected component (if applicable): 2.6.9-34.EL (tg3
v3.43-rh)


How reproducible: Always


Steps to Reproduce:
1. Define multiple VLAN interfaces on RHEL4 kernel 2.6.9-34.EL using a tg3
interface.
2. Boot the system
3. Observe that the first-initialized VLAN interface will not pass any traffic.
  
Actual results: VLAN interface passes not traffic and is not pingable.


Expected results: VLAN interface should work.  :)


Additional info: Upon googling I found a similar bug reported for CentOS here:
http://bugs.centos.org/view.php?id=1276
Comment 1 Jason Baron 2006-04-26 12:52:19 EDT
hi Steve,

this looks like a duplicate of 188087 which we have fixed in the U4 beta...if
you want to try that kernel: http://people.redhat.com/~jbaron/rhel4/

Please re-open this if this is a separate issue.

thanks.

*** This bug has been marked as a duplicate of 188087 ***
Comment 2 Steve Snodgrass 2006-04-27 11:11:37 EDT
I did do a Bugzilla search before I posted this.  When I try to view 188087 I
get "Access Denied  You are not authorized to access bug #188087."

Note You need to log in before you can comment on or make changes to this bug.