Bug 19002 - gnorpm-0.95.1-3.src.rpm will not rebuild on redhat 7.0
gnorpm-0.95.1-3.src.rpm will not rebuild on redhat 7.0
Status: CLOSED DUPLICATE of bug 19220
Product: Red Hat Linux
Classification: Retired
Component: gnorpm (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Dale Lovelace
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-12 18:00 EDT by tannhaus
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-18 03:32:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tannhaus 2000-10-12 18:00:30 EDT
I try to rebuild the rpm with the following:

rpm --rebuild gnorpm-0.95.1-3.src.rpm

During the configure phase I get the following error:

configure: error:  can't find librpm (usually in rpm-devel package)
Bad exit status from /var/tmp/rpm-temp.22363 (%build)

But, when I type 'whereis librpm' I get :
librpm: /usr/lib/librpm.a /usr/lib/librpm.la /usr/lib/librpm.so

and when I type rpm -q rpm-devel I get:
rpm-devel-4.0-4

I downloaded the source rpm again, reinstalled the rpm-devel rpm, ran
ldconfig....all with no change.
Comment 1 tannhaus 2000-10-12 18:02:13 EDT
On an additional note, I installed the gnome i386.rpm and it works fine.
Comment 2 tannhaus 2000-10-12 18:10:57 EDT
I change my previous comment....as soon as I select a package to install and
click to add it, gnorpm segfaults.  This is on the i386 rpm on redhat 7.0
Comment 3 Need Real Name 2000-10-13 09:08:34 EDT
On my fresh installed RH 7.0 (i386) box gnorpm-0.95.1-3 segfaults
immediatly after pressing the install button. This also
happen when i compiled the source from ftp.gnome.org and did
not go away after installing helix gnome. gnorpm 0.90 works!
Comment 4 Alan Cox 2000-10-14 13:40:10 EDT
This appears to be an RPM4 library problem. The same code is working correctly
on rpmlib 3.x

Reassigned to rpm as rpmlib has no package of its own
Comment 5 Jeff Johnson 2000-10-15 19:35:00 EDT
Where did you get gnorpm-0.95.1-3.src/rpm? I've tried "rpm --rebuild ..." as
well
as installing and rebuilding from the spec file, and both work fine for me using
the Red Hat gnorpm-0.95.1.src.rpm.

The segfault is also non-reproducible for me? Perhaps you have installed a
version
compiled against rpm-3.0.x libraries, but are running with rpm-4.0 libraries ...
Comment 6 tannhaus 2000-10-15 20:01:28 EDT
http://www.redhat.com/support/errata/RHSA-2000-072-05.html

That's where I saw it.  I think I downloaded it from the sourceforge mirror. 
But it won't build and if you just install the prebuilt RPM it segfaults as soon
as you click install after adding a package to be installed.  

Comment 7 Jeff Johnson 2000-10-16 01:07:54 EDT
OK, I've downloaded the src.rpm from the URL, and "rpm --rebuild" works.
Something
else is going on. If you attach the output of "rpm -qa"  to this bug, I'll take
a look.
Comment 8 tannhaus 2000-10-16 01:20:46 EDT
xfishtank-2.1tp-1
mondo-vfat-1.2-1
ld.so-1.9.5-13
tdfx_drm-1.0-3
ncurses3-1.9.9e-11
SDL_mixer-1.0.6-1
afio-2.4.6-1
SDL_mixer-devel-1.0.6-1
xmp-2.0.2-3
gtoaster-0.4.2000082921-1
filesystem-2.0.7-1
compat-glibc-6.2-2.1.3.2
libtermcap-2.0.8-25
ncurses-5.1-2
audiofile-devel-0.1.9-7
bison-1.28-5
cdda2wav-1.9-2
mingetty-0.9.4-13
popt-1.6-4
which-2.11-4
initscripts-5.49-1
XFree86-xfs-4.0.1-1
pwdb-0.61.1-1
SysVinit-2.78-10
compat-libstdc++-6.2-2.9.0.9
cpio-2.4.2-20
ctags-4.0.2-1
dhcpcd-1.3.18pl8-6
dosfstools-2.2-8
eject-2.0.2-6
findutils-4.1.5-4
freetype-1.3.1-7
gd-1.8.3-4
gdbm-devel-1.8.0-5
ghostscript-5.50-7
gnome-audio-1.0.0-12
gnome-linuxconf-0.33-7
gpm-devel-1.19.3-4
gtk-engines-0.10-9
ical-2.2-19
indent-2.2.5-6
iputils-20000418-6
RealPlayer-7.0-7
sh-utils-2.0-11
less-358-7
libjpeg-devel-6b-13
libstdc++-2.96-54
libtiff-devel-3.5.5-7
libtool-libs-1.3.5-8
lilo-21.4.4-10
lynx-2.8.4-3
MAKEDEV-3.0.6-5
mkbootdisk-1.2.8-2
ncompress-4.2.4-20
netcfg-2.36-1
netscape-common-4.75-2
ntsysv-1.2.16-1
openssl-0.9.5a-14
passwd-0.64.1-4
playmidi-2.4-12
procmail-3.14-5
pygnome-libglade-0.6.6-4
python-devel-1.5.2-27
redhat-logos-1.1.2-3
sawfish-0.30.3-10
sharutils-4.2.1-7
smpeg-0.4.0-5
switchdesk-3.6-1
tcp_wrappers-7.6-15
tkinter-1.5.2-27
unzip-5.41-3
util-linux-2.10m-12
Xaw3d-1.5-7
XFree86-100dpi-fonts-4.0.1-1
XFree86-twm-4.0.1-1
xinetd-2.1.8.9pre9-6
xpdf-0.91-1
zip-2.3-8
dhcp-2.0-12
gimp-data-extras-1.1.20-3
open-1.4-10
readline2.2.1-2.2.1-2
xmms-devel-1.2.2-4
FaxMail-2.3-5
glib-1.2.8-4
db1-1.85-4
libunicode-devel-0.4-0_helix_1
libpng-1.0.8-1
e2fsprogs-1.18-16
sysklogd-1.3.33-8
glibc-2.1.94-3
pan-0.9-1
w3c-libwww-devel-5.2.8-6
kdeadmin-2.0rc2-1
kdelibs-2.0rc2-2
kdemultimedia-2.0rc2-1
kdesupport-devel-2.0rc2-1
koffice-2.0rc2-1
qt-designer-2.2.1-3
tdfx_dri_devel-4.0.1-1
mondo-extras-1.7-1
krb5-configs-1.1.1-21
helptool-2.4-9
nag-1.0-4
sag-0.6-3
svgalib-1.4.1-2
Glide_SDK-2.2-16
mtv-1.1.4-1
kvirc-2.0.0-1
Glide3x_devel-2.1-6
xv-3.10a-15
mtv-fullscreen-extension-1.1.4-1
cdrecord-mkhybrid-1.8.1-1
mondo-0.975-1
setup-2.3.4-1
basesystem-7.0-2
chkconfig-1.2.16-1
termcap-11.0.1-3
bash-2.04-11
info-4.0-15
grep-2.4.2-4
aspell-0.32.5-1
audiofile-0.1.9-7
authconfig-4.0.16-4
automake-1.4-8
bdflush-1.5-14
binutils-2.10.0.18-1
byacc-1.9-16
bzip2-devel-1.0.1-3
cdecl-2.5-15
sed-3.02-8
gawk-3.0.6-1
procps-2.0.7-3
logrotate-3.5.2-1
psmisc-19-4
vixie-cron-3.0.1-56
shadow-utils-19990827-18
textutils-2.0e-8
zlib-1.1.3-12
cracklib-2.7-8
cracklib-dicts-2.7-8
pam-0.72-26
chkfontpath-1.7.2-5
compat-egcs-c++-6.2-1.1.2.9
console-tools-19990829-25
control-panel-3.18-2
cpp-2.96-54
crontabs-1.8-1
cvs-1.10.8-8
desktop-backgrounds-1.1-4
dev86-0.15.0-5
dialog-0.9a-3
diffutils-2.7-21
ee-0.3.12-1
emacs-20.7-14
expect-5.31-46
file-3.30-7
finger-0.17-4
fortune-mod-1.0-13
ftp-0.17-6
gcc-c++-2.96-54
gd-devel-1.8.3-4
gdbm-1.8.0-5
gdk-pixbuf-0.8.0-5
gettext-0.10.35-23
ghostscript-fonts-5.50-3
gimp-devel-1.1.25-1
gmp-3.0.1-5
gnome-libs-devel-1.2.4-11
gpm-1.19.3-4
groff-1.16-7
gtk+-devel-1.2.8-7
gv-3.5.8-11
hdparm-3.9-6
ImageMagick-5.2.2-5
imlib-devel-1.9.8.1-2
indexhtml-7.0-2
iproute-2.2.4-7
isapnptools-1.22-2
kernel-2.2.16-22
kernel-utils-2.2.16-22
kgcc-1.1.2-40
krb5-libs-1.2.1-8
kudzu-devel-0.72-3
libghttp-1.0.6-4
libjpeg-6b-13
librep-0.12.1-3
libstdc++-devel-2.96-54
libtiff-3.5.5-7
m4-1.4.1-3
libtool-1.3.5-8
libungif-4.1.0-7
libxml-1.8.9-5
linuxconf-1.19r2-4
losetup-2.10m-5
mailcap-2.0.9-2
make-3.79.1-5
man-1.5h1-10
mikmod-3.1.6-9
mkinitrd-2.6-1
mkxauth-1.7-15
mouseconfig-4.13-2
mtools-3.9.7-3
ncurses-devel-5.1-2
net-tools-1.56-2
netpbm-9.5-5
netpbm-progs-9.5-5
netscape-communicator-4.75-2
newt-devel-0.50.17-1
sgml-common-0.1-10
openssl-devel-0.9.5a-14
ORBit-devel-0.5.3-2
patch-2.5.4-4
pidentd-3.0.10-11
playmidi-X11-2.4-12
pmake-2.1.34-6
pspell-0.11.2-1
pygnome-1.0.53-4
pygtk-0.6.6-4
python-1.5.2-27
pythonlib-1.27-1
qt1x-devel-1.45-11
readline-devel-4.1-5
redhat-release-7.0-1
rep-gtk-gnome-0.13-3
rootfiles-7.0-4
rpm-build-4.0-4
rpm-python-4.0-4
sash-3.4-8
screen-3.9.5-13
SDL-devel-1.1.4-1
sgml-tools-1.0.9-8
slang-1.4.1-5
slocate-2.2-5
sox-12.16-11
SVGATextMode-1.9-7
tar-1.13.17-8
tclx-8.2.0-46
tcsh-6.09-6
time-1.7-12
timetool-2.7.4-3
tk-8.3.1-46
umb-scheme-3.2-16
urw-fonts-2.0-8
utempter-0.5.2-4
whois-1.0.3-2
Xaw3d-devel-1.5-7
XFree86-devel-4.0.1-1
XFree86-tools-4.0.1-1
XFree86-VGA16-3.3.6-33
xinitrc-2.9.10-1
xmms-1.2.2-4
xxgdb-1.12-16
zlib-devel-1.1.3-12
getty_ps-2.0.7j-12
glib10-1.0.6-9
libjpeg6a-6a-7
procinfo-17-7
usbview-0.8.1-2
xtoolwait-1.2-5
tdfx_dri-4.0.1-1
glib-devel-1.2.8-4
db1-devel-1.85-4
db3-3.1.14-6
libpng-devel-1.0.8-1
gnome-core-1.2.1-33
esound-0.2.20-1
mount-2.10m-6
tmpwatch-2.6.2-1.7
glibc-devel-2.1.94-3
gnorpm-0.95.1-3
libxml-devel-1.8.9-5
w3c-libwww-5.2.8-6
rpm-devel-4.0-4
htdig-3.2.0-0.b2
kdebase-2.0rc2-1
kdegraphics-2.0rc2-1
kdelibs-devel-2.0rc2-2
kdelibs-sound-devel-2.0rc2-2
kdenetwork-2.0rc2-1
kdesupport-2.0rc2-1
kdetoys-2.0rc2-1
kdoc-2.0rc2-1
libmng-0.9.2-1
qt-2.2.1-3
qt-devel-2.2.1-3
XFree86-xf86cfg-4.0.1-1
xscreensaver-3.25-4
fetchmailconf-5.5.0-2
joystick-1.2.15-5
qt1x-GL-1.45-11
smpeg-devel-0.4.0-5
XFree86-4.0.1-1
libc-5.3.12-31
svgalib-devel-1.4.1-2
xanim-2.80.1-7
gaim-0.9.20-1
mktemp-1.5-5
anacron-2.3-9
fileutils-4.0x-3
at-3.1.8-12
autoconf-2.13-9
bind-utils-8.2.2_P5-25
bzip2-1.0.1-3
cdrecord-1.9-2
modutils-2.3.14-3
XFree86-libs-4.0.1-1
words-2-16
compat-egcs-6.2-1.1.2.9
control-center-1.2.1-5
cproto-4.6-5
cyrus-sasl-1.5.24-6
dev-3.0.6-5
diffstat-1.27-5
ed-0.2-17
emacs-X11-20.7-14
fetchmail-5.5.0-2
gcc-2.96-54
gdb-5.0-7
gdk-pixbuf-devel-0.8.0-5
gimp-1.1.25-1
gnome-libs-1.2.4-11
gnupg-1.0.2-4
gtk+-1.2.8-7
gzip-1.3-6
imlib-1.9.8.1-2
ipchains-1.3.9-17
kbdconfig-1.9.7-3
kernelcfg-0.6-9
kudzu-0.72-3
libglade-0.13-4
libtermcap-devel-2.0.8-25
perl-5.6.0-9
libungif-devel-4.1.0-7
linuxconf-devel-1.19r2-4
mailx-8.1.1-20
man-pages-1.30-4
mkisofs-1.9-2
mpg123-0.59r-8
ncurses4-5.0-2
netpbm-devel-9.5-5
newt-0.50.17-1
openjade-1.3-6
ORBit-0.5.3-2
pciutils-2.1.8-8
plugger-3.2-8
pump-0.8.3-2
pygtk-libglade-0.6.6-4
qt1x-1.45-11
readline-4.1-5
rep-gtk-0.13-3
rpm-4.0-4
rwho-0.17-6
SDL-1.1.4-1
slang-devel-1.4.1-5
stat-2.2-1
tcl-8.3.1-46
telnet-0.17-7
tix-4.1.0.6-46
traceroute-1.4a5-23
Xconfigurator-4.4.3-1
XFree86-SVGA-3.3.6-33
XFree86-xdm-4.0.1-1
xloadimage-4.1-16
xsri-1.0-8
cdrecord-devel-1.9-2
freetype-devel-1.3.1-7
gtk+10-1.0.6-9
libungif-progs-4.1.0-7
symlinks-1.2-11
licq-0.85-1
Glide_V3-DRI-3.10-6
libunicode-0.4-0_helix_1
db2-2.4.14-4
esound-devel-0.2.20-1
usermode-1.36-3
libghttp-devel-1.0.6-4
flex-2.5.4a-13
kdegames-2.0rc2-1
kdelibs-sound-2.0rc2-2
kdepim-2.0rc2-1
kdeutils-2.0rc2-1
libmng-devel-0.9.2-1
qt-Xt-2.2.1-3
Comment 9 Jim Hayward 2000-10-17 02:43:57 EDT
You are missing db3-devel-3.1.14-6.i386.rpm. I had the same problem with "rpm
--rebuild" on this package. Installing it will fix the problem. You might want
to apply the fix listed in bug report 19220 by alan before you rebuild it, this
will cure the segmentation fault bug I reported in bug 18930.
Comment 10 tannhaus 2000-10-17 23:38:48 EDT
I tried to do that, but can't get the patch to work.  Can't redhat just release
an updated srpm since this IS a bug?
Comment 11 Jim Hayward 2000-10-18 03:32:27 EDT
I'm sure Redhat will release updated rpm's as soon as they have been fully
tested. However if you require this fix immediately reply to my email and tell
me to what email address you would like it sent and I will send you the SRPM I
created with the patch applied to use until Redhat releases an official update.
Comment 12 Jeff Johnson 2000-10-18 09:46:34 EDT

*** This bug has been marked as a duplicate of 19220 ***

Note You need to log in before you can comment on or make changes to this bug.