Bug 190026 - Missing curly brackets in pam_namespace.c cause runtime errors
Missing curly brackets in pam_namespace.c cause runtime errors
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pam (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-26 15:54 EDT by Valdis Kletnieks
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: pam-0.99.4.0-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-10 11:08:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add proper curly brackets to make the code work (917 bytes, patch)
2006-04-26 15:54 EDT, Valdis Kletnieks
no flags Details | Diff

  None (edit)
Description Valdis Kletnieks 2006-04-26 15:54:59 EDT
Description of problem:
Missing curly brackets in pam_namespace.c cause PAM_SESSION_ERR to be returned
incorrectly, creating failures at runtime.  The code indentation even shows what
was intended, the brackets were forgotten and what was compiled acted differently.

Version-Release number of selected component (if applicable):
pam-0.99.3.0-3

How reproducible:
Try to use polyinstantiation.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
pam_namespace(login:session): Error getting instance name


Expected results:


Additional info:
Comment 1 Valdis Kletnieks 2006-04-26 15:54:59 EDT
Created attachment 128272 [details]
Add proper curly brackets to make the code work

Note You need to log in before you can comment on or make changes to this bug.