Bug 190064 - No CD-ROM/DVD and Floppy available. Directory "/media" empty
No CD-ROM/DVD and Floppy available. Directory "/media" empty
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Daniel Walsh
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-27 04:58 EDT by Claudio Tibaldi
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-20 07:42:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
avc error (356.52 KB, application/octet-stream)
2006-05-04 15:34 EDT, Claudio Tibaldi
no flags Details

  None (edit)
Description Claudio Tibaldi 2006-04-27 04:58:41 EDT
Description of problem:
No CD-ROM/DVD and floppy available. Directory "/media" empty. When insert a cd
no spinup no life sign.

Version-Release number of selected component (if applicable): 
System full update (desktop manager=KDE)


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Claudio Tibaldi 2006-04-27 13:14:28 EDT
Ddisabling SELinux, Floppy appear under system:/media but introducing a dvd-rom
or cd-rom and trying to open it an error appear "Malformed URL." and I can not
read the dvd/cd.
Comment 2 John (J5) Palmieri 2006-04-27 13:22:11 EDT
Looks like a KDE and SELinux issue.
Comment 3 Ngo Than 2006-04-27 13:30:38 EDT
which version of kdebase? This issue should be fixed in kdebase-3.5.2-0.2.fc5,
which is available in fc5 update. Please reopen it again if the problem
still appears. Thanks
Comment 4 Claudio Tibaldi 2006-04-28 04:09:49 EDT
Introducing a dvd-rom or cd-rom and trying to open it an error appear "Malformed
URL." and I can not read the dvd/cd.
As I Written my system is updated. Anyway, it's the second time I found the rpm
package installed in two different version after yumex update. Now I found
kdebase-3.5.2-0.2.fc5 and kdebase-3.5.1-5 installed.
Why hal-device-manager not run if I enable SELinux?


Thank you. Ciao
Claudio Tibaldi
Comment 5 Ngo Than 2006-04-28 04:34:46 EDT
it's probably a bug in selinux.
Comment 6 Daniel Walsh 2006-05-01 15:59:32 EDT
Are you seeing avc messages in /var/log/messages or /var/log/audit/audit.log
Comment 7 Claudio Tibaldi 2006-05-03 15:15:53 EDT
here are the errors in messages when insert a cd and double clic to open it:
May  3 21:20:53 McKlaud kernel: cdrom: This disc doesn't have any tracks I
recognize!
May  3 21:21:11 McKlaud automount[2763]: >> /usr/sbin/showmount: can't get
address for .directory
May  3 21:21:11 McKlaud automount[2763]: lookup(program): lookup for .directory
failed
May  3 21:21:11 McKlaud automount[2763]: failed to mount /net/.directory
Comment 8 Daniel Walsh 2006-05-03 15:22:31 EDT
Have you yum updated to the latest selinux policy?

Do you see any "avc" messages in the log files?

grep avc /var/log/messages

If you setenforce 0 as root does the disk show up?
Comment 9 Claudio Tibaldi 2006-05-04 15:34:51 EDT
Created attachment 128627 [details]
avc error
Comment 10 Claudio Tibaldi 2006-05-04 16:12:56 EDT
Have you yum updated to the latest selinux policy? YES

Do you see any "avc" messages in the log files? I'm sorry but i don't know what
is "avc". Anyway here is attach content all avc messages.

If you setenforce 0 as root does the disk show up? I have disabled SELinux
before open this bug. Anyway run "setenforce 0" and the the problem is always
the same.

I'm not sure that is a SELinux problem because disabling or "setenforce 0"
anything has changed.

ciao
Comment 12 Daniel Walsh 2006-05-09 16:08:10 EDT
Fixes in selinux-policy-2.2.38-1.fc5 should help with this problem
Comment 13 Claudio Tibaldi 2006-05-10 14:17:16 EDT
Nothing is changed and re-enabling SELinux in system:/media there are only hdd
icons, NO DVD/CD-ROM, NO FLOPPY. Here is messages error:
May 10 20:12:03 McKlaud automount[2557]: >> /usr/sbin/showmount: can't get
address for .directory
May 10 20:12:03 McKlaud automount[2557]: lookup(program): lookup for .directory
failed
May 10 20:12:03 McKlaud automount[2557]: failed to mount /net/.directory
May 10 20:12:54 McKlaud kernel: cdrom: This disc doesn't have any tracks I
recognize!
May 10 20:13:41 McKlaud kernel: audit(1147284821.541:10): avc:  granted  {
setenforce } for  pid=2596 comm="setenforce"
scontext=system_u:system_r:unconfined_t:s0
tcontext=system_u:object_r:security_t:s0 tclass=security
May 10 20:15:22 McKlaud automount[2704]: >> /usr/sbin/showmount: can't get
address for .directory
May 10 20:15:22 McKlaud automount[2704]: lookup(program): lookup for .directory
failed
May 10 20:15:22 McKlaud automount[2704]: failed to mount /net/.directory
May 10 20:16:41 McKlaud automount[2719]: >> /usr/sbin/showmount: can't get
address for .directory
May 10 20:16:41 McKlaud automount[2719]: lookup(program): lookup for .directory
failed
May 10 20:16:41 McKlaud automount[2719]: failed to mount /net/.directory

Any idea?
Comment 14 Daniel Walsh 2006-05-11 10:06:13 EDT
What version of policy are you now running? 

Does it work if you execute

setenforce 0

If it does not it, might not be an SELinux problem.

Do you see any avc messages?

If not can you execute the following

semodule -b /usr/share/selinux/targeted/enableaudit.pp

Then try to use the floppy/cdrom

Now look for avc messages in /var/log/messages or /var/log/audit/audit.log

Comment 15 Claudio Tibaldi 2006-05-13 09:56:39 EDT
I'm running the latest but as I wrote a lot of time my problesit with SELinux
disable also. Here are the errors in /var/log/messages with SELinux enable:

May 13 15:40:56 kernel: cdrom: This disc doesn't have any tracks I recognize!
May 13 15:41:48 automount[2609]: >> /usr/sbin/showmount: can't get address for
.directory
May 13 15:41:48 automount[2609]: lookup(program): lookup for .directory failed
May 13 15:41:48 automount[2609]: failed to mount /net/.directory.

There is only one difference between SELinux disable or enable, when in enable
in the system:/media there isn't floppy and cd-rom icon.
Anyway I don't think is a SELinux problem. Do you?
Comment 16 Daniel Walsh 2006-05-15 12:28:22 EDT
The icon not showing up might be a problem, but could also be a hal problem.

Did you try the enableaudit.pp file I mentioned above.  I am adding Hal
maintainer to see if he has any ideas.
Comment 17 Claudio Tibaldi 2006-05-20 07:42:00 EDT
I've reinstalled FC5 and seems all ok.
Close case.
Bye bye.

Note You need to log in before you can comment on or make changes to this bug.