Bug 190078 - Multiple different specifications for /opt
Multiple different specifications for /opt
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Russell Coker
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-27 07:57 EDT by Aurelien Bompard
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-01 15:31:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aurelien Bompard 2006-04-27 07:57:58 EDT
Description of problem:
When running restorecon, I get:
/etc/selinux/targeted/contexts/files/file_contexts: Multiple different
specifications for /opt  (system_u:object_r:home_root_t and
system_u:object_r:usr_t).

This happens since the update to 2.2.34-3

Version-Release number of selected component (if applicable):
# rpm -q selinux-policy-targeted
selinux-policy-targeted-2.2.34-3.fc5
Comment 1 Daniel Walsh 2006-04-27 11:28:43 EDT
Do you have users with homedirectories under /opt?

Dan
Comment 2 Aurelien Bompard 2006-04-27 11:48:43 EDT
Yes, good catch !
$ grep opt /etc/passwd
zimbra:x:506:506::/opt/zimbra:/bin/bash

Comment 3 Daniel Walsh 2006-05-01 15:27:02 EDT
Can you move that directory?
At least create /opt/home/zimbra
Comment 4 Daniel Walsh 2006-05-01 15:31:08 EDT
Actually zimbra is not a login account so the UID should be less then 500 and
the login shell should be /bin/false or /sbin/nologin.  Could you report this as
a bug to the Zimbra folks.

You can change the shell 

usermod -s /sbin/nologin zimbra 

to eliminate your problem.

Comment 5 Aurelien Bompard 2006-05-01 17:14:36 EDT
OK, I've userdel'ed zimbra (I uninstalled it a few days ago), and I still get
the warning:
# restorecon -R /opt
/etc/selinux/targeted/contexts/files/file_contexts: Multiple different
specifications for /opt  (system_u:object_r:home_root_t and
system_u:object_r:usr_t).

There is no more /opt in /etc/passwd.
Comment 6 Daniel Walsh 2006-05-01 17:37:08 EDT
Run genhomedircon

Note You need to log in before you can comment on or make changes to this bug.