Bug 19009 - netstat -i produces different output
Summary: netstat -i produces different output
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: net-tools   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-13 00:46 UTC by Jay
Modified: 2007-04-18 16:29 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-23 15:55:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jay 2000-10-13 00:46:02 UTC
in redhat 7.0, the command netstat -i is producing output like that of 
ifconfig, instead of the normal table format with each interface listed.  
i sent this message to the guinness list, and got no response from anyone 
inside redhat.  is this a bug??  or did someone deliberately change the 
output??

jason

Comment 1 Jay 2000-10-13 11:22:03 UTC
I suppose I should explain my position better.  I am looking to see if this is 
a feature change.  If indeed it is, then I don't see the point, because the 
same output can be produced by ifconfig.  As pointed out by the single beta 
tested who responded, it seems more like functionality loss and we can't really 
see a benefit to the change.  Thanks

Comment 2 Jeff Johnson 2000-10-15 23:05:11 UTC
No feature change, the previous tabular format is displayed in net-tools-1.57-1.
Dunno what's
up with net-tools-1.56-2 yet ...

Comment 3 Jay 2000-11-03 00:29:28 UTC
Is there a status on this being fixed??  Its a really annoying change in 
functionality.  Thanks

Comment 4 Scott Gibson 2001-03-23 15:55:01 UTC
I am also having the same problem with netstat.  I'm using net-tools-1.56-2

Comment 5 Crutcher Dunnavant 2001-04-19 18:45:57 UTC
netstat 1.57 & 1.60 give tabular output

Comment 6 Rang 2004-09-09 13:14:46 UTC
well the output is not aligned properly c the follwing:-

Kernel Interface table
Iface   MTU Met   RX-OK RX-ERR RX-DRP RX-OVR   TX-OK TX-ERR TX-DRP TX-
OVR Flg
eth0   1500   059740687      0      0      0104515256      0      
0      0 BMRU
lo    16436   0  739866      0      0      0  739866      0      
0      0 LRU



Note You need to log in before you can comment on or make changes to this bug.