Bug 190093 - mysql_config script should be in -devel package
mysql_config script should be in -devel package
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: mysql (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Lane
David Lawrence
:
Depends On:
Blocks: 176344
  Show dependency treegraph
 
Reported: 2006-04-27 10:53 EDT by Bastien Nocera
Modified: 2013-07-02 23:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-29 22:24:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2006-04-27 10:53:26 EDT
$ rpm -qpl mysql-4.1.12-3.RHEL4.1.ppc64.rpm | grep mysql_config
/usr/bin/mysql_config
/usr/lib64/mysql/mysql_config
$ rpm -qpl mysql-4.1.12-3.RHEL4.1.ppc.rpm | grep mysql_config
/usr/bin/mysql_config
/usr/lib/mysql/mysql_config

Just like for the "gtk", or similar package with a "*-config" script. Here's a
list of packages that do this properly on a standard RHEL4 box:
$ rpm -qf /usr/bin/*-config | grep -- -devel
apr-devel-0.9.4-24.5
apr-util-devel-0.9.4-21
audiofile-devel-0.2.6-1
libcroco-devel-0.6.0-4
cups-devel-1.1.22-0.rc1.9.10
esound-devel-0.2.35-2
freetype-devel-2.1.9-1
libgpg-error-devel-1.0-1
libart_lgpl-devel-2.3.16-3
libgcrypt-devel-1.2.0-3
gnutls-devel-1.0.20-3.2.2
gnutls-devel-1.0.20-3.2.2
libpng-devel-1.2.7-1.el4.2
libpng-devel-1.2.7-1.el4.2
libusb-devel-0.1.8-3
linc-devel-1.0.3-6
mozilla-nspr-devel-1.7.12-1.4.2
net-snmp-devel-5.1.2-11.EL4.6
openobex-devel-1.0.1-1
ORBit2-devel-2.12.0-3
pcre-devel-4.5-3.2.RHEL4
SDL-devel-1.2.7-8
libxml2-devel-2.6.16-6
libxslt-devel-1.1.11-1
Comment 2 Tom Lane 2006-04-27 11:46:58 EDT
mysql_config needs to be in the base package because it is used for non-devel
purposes as well as devel ones.  What is the actual problem you are trying to
solve?
Comment 3 Bastien Nocera 2006-04-27 11:54:12 EDT
Get a machine with a multilib environment (x86-64, PPC64) and try to compile
something that requires the mysql libraries for 32-bit. The binary will point to
the 64-bit version of mysql_config, despite both the 32-bit and 64-bit versions
being installed.

The program in question was cyrus-sasl using the .spec we ship.
Comment 4 Tom Lane 2006-04-27 13:30:05 EDT
Well, we can't just remove mysql_config without breaking perl, php, ruby, and
everything else that expects to use "mysql_config --socket" to find out where
the socket is.  Arguably they shouldn't be doing that, but it's a mighty
widespread meme.
Comment 7 Tom Lane 2006-08-29 22:24:38 EDT
OK, closing bz entry as WONTFIX.  I don't say that this isn't an interesting question, but the correct 
packaging behavior is not immediately apparent.

Note You need to log in before you can comment on or make changes to this bug.