Bug 190147 - scp exiting non-zero on success
scp exiting non-zero on success
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openssh (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
: Regression
: 190757 197750 (view as bug list)
Depends On:
Blocks: 181409
  Show dependency treegraph
 
Reported: 2006-04-28 01:47 EDT by jjh-redhat-bugzilla
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2006-0303
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-10 17:20:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Output from openssh-3.9p1-8.RHEL4.9 (298 bytes, text/plain)
2006-04-28 01:47 EDT, jjh-redhat-bugzilla
no flags Details
output from openssh-3.9p1-8.RHEL4.12 (299 bytes, text/plain)
2006-04-28 01:48 EDT, jjh-redhat-bugzilla
no flags Details
test case script (503 bytes, text/plain)
2006-04-28 01:50 EDT, jjh-redhat-bugzilla
no flags Details

  None (edit)
Description jjh-redhat-bugzilla 2006-04-28 01:47:07 EDT
Description of problem:

With the latestup update to openssh, when doing an 'scp user@host:/path/to/src
file user@host:/path/to/destination' style scp command, it exits 1 instead of 0
on success.  

with -vvv option it shows:

debug1: Exit status 0
but echo $? => 1

Version-Release number of selected component (if applicable):

openssh-3.9p1-8.RHEL4.12

How reproducible:

Every time.  Test case script attached.

Steps to Reproduce:

    Use attached script.
  
Actual results:

    $ scp user@localhost:/tmp/junk.dat user@localhost:/tmp/junk.dat.copy
    $ echo $?
    1

Expected results:
    $ scp user@localhost:/tmp/junk.dat user@localhost:/tmp/junk.dat.copy
    $ echo $?
    0

Additional info:
Comment 1 jjh-redhat-bugzilla 2006-04-28 01:47:08 EDT
Created attachment 128341 [details]
Output from openssh-3.9p1-8.RHEL4.9
Comment 2 jjh-redhat-bugzilla 2006-04-28 01:48:22 EDT
Created attachment 128342 [details]
output from openssh-3.9p1-8.RHEL4.12
Comment 3 jjh-redhat-bugzilla 2006-04-28 01:50:07 EDT
Created attachment 128343 [details]
test case script
Comment 7 Tomas Mraz 2006-05-04 18:47:39 EDT
*** Bug 190757 has been marked as a duplicate of this bug. ***
Comment 8 Tomas Mraz 2006-07-07 08:21:18 EDT
*** Bug 197750 has been marked as a duplicate of this bug. ***
Comment 11 Red Hat Bugzilla 2006-08-10 17:20:07 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0303.html

Note You need to log in before you can comment on or make changes to this bug.