Bug 19021 - rc.sysinit attempts to use non-existent modules
Summary: rc.sysinit attempts to use non-existent modules
Status: CLOSED DUPLICATE of bug 17454
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 7.3
Hardware: alpha
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-13 04:33 UTC by Michal Jaegermann
Modified: 2014-03-17 02:16 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-13 04:33:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Jaegermann 2000-10-13 04:33:39 UTC
On UP1100 machine kudzu finds the following:

class: USB
bus: PCI
detached: 0
driver: usb-ohci
desc: "Acer Laboratories Inc. [ALi]|M5237 USB"
vendorId: 10b9
deviceId: 5237
subVendorId: 0000
subDeviceId: 0000
pciType: 1

This is causing

Initializing USB controller (usb-ohci): modprobe: Can't locate module
usb-ohci

during a startup as this module, indeed, does not exist.

'rc.sysinit' should not attempt to insert absent modules.  Even if a
distribution would provide that module then there is nothing which
says that a custom kernel was compiled with it either.  A quick grep
through  /lib/modules/$(uname -r)/modules.dep would solve that problem.

  Michal
  michal@harddata.com

Comment 1 Bill Nottingham 2000-10-16 16:44:36 UTC

*** This bug has been marked as a duplicate of 17454 ***


Note You need to log in before you can comment on or make changes to this bug.