Bug 190250 - gnome-sudoku won't start
gnome-sudoku won't start
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-sudoku (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul W. Frields
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-29 05:46 EDT by Steve
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-30 09:47:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steve 2006-04-29 05:46:51 EDT
Description of problem:
gnome-sudoku won't start

Version-Release number of selected component (if applicable):
gnome-sudoku-0.4.0-5.fc5

How reproducible:
Traceback (most recent call last):
  File "/usr/bin/gnome-sudoku", line 11, in ?
    start_game()
  File "/usr/lib/python2.4/site-packages/gnome_sudoku/gnome_sudoku.py", line
876, in start_game
    u = UI()
  File "/usr/lib/python2.4/site-packages/gnome_sudoku/gnome_sudoku.py", line
336, in __init__
    self.sudoku_maker = sudoku_maker.SudokuMaker()
  File "/usr/lib/python2.4/site-packages/gnome_sudoku/sudoku_maker.py", line
309, in __init__
    self.load()
  File "/usr/lib/python2.4/site-packages/gnome_sudoku/sudoku_maker.py", line
394, in load
    loaded = pickle.load(ifi)
  File "/usr/lib/python2.4/pickle.py", line 1390, in load
    return Unpickler(file).load()
  File "/usr/lib/python2.4/pickle.py", line 872, in load
    dispatch[key](self)
  File "/usr/lib/python2.4/pickle.py", line 894, in load_eof
    raise EOFError
EOFError

Steps to Reproduce:
1. start a terminal
2. type: gnome-sudoku
3. errors about python2.4 will appear
  
Actual results:


Expected results:


Additional info:
Comment 1 Paul W. Frields 2006-04-29 20:02:39 EDT
I can't reproduce this error here.  I am told that this error might be evidence
of a corrupted pickle file.  Check your home directory for any such "leftovers"
from Python.
Comment 2 Steve 2006-04-30 04:14:20 EDT
there is no file or directory called "python" or "gnome-sudoku" in the home
directory.
Comment 3 Paul W. Frields 2006-04-30 08:25:26 EDT
The directory in question is ~/.gnome2/gnome-sudoku.  Move or remove the
directory and/or its contents and try again.
Comment 4 Steve 2006-04-30 09:47:42 EDT
you are right, problem solved, ticked closed!

Note You need to log in before you can comment on or make changes to this bug.