Bug 190264 - Hard crash during xen0 bootup if audio CD is in CD-ROM drive
Hard crash during xen0 bootup if audio CD is in CD-ROM drive
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
5
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Xen Maintainance List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-29 13:19 EDT by Robin Green
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.16-1.2118_FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-19 17:56:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Green 2006-04-29 13:19:51 EDT
Description of problem:
When Fedora is run under xen, using the latest xen0 kernel, if an audio CD is 
in the CD-ROM drive during bootup, it crashes while printing an error message 
about the CD-ROM drive, and will not respond to CTRL+ALT+DEL.

Version-Release number of selected component (if applicable):
kernel-xen0-2.6.16-1.2096_FC5
xen-3.0.1-4

How reproducible:
Always

Steps to Reproduce:
1. Insert audio CD in CD-ROM drive
2. Boot with the following options (IMPORTANT: two workaround options, 
sync_console and pnpacpi=off, to get the serial console to work must not be 
used, because when they are used the bug will not happen)
        kernel /xen.gz-2.6.16-1.2096_FC5 console=com1 com1=115200,8n1 
dom0_mem=600M
        module /vmlinuz-2.6.16-1.2096_FC5xen0 ro root=/dev/VolGroup00/LogVol01 
console=ttyS0 console=tty0
        module /initrd-2.6.16-1.2096_FC5xen0.img
Probably most of these options are not necessary!
  
Actual results:
After a message about starting the HAL daemon, many error messages about 
accessing hda are printed, and the system hard-crashes during printing one of 
those messages.

Expected results:
No crash

Additional info:
Does not occur if the abovementioned workaround kernel options are used; does 
not occur when not running on xen. In both cases, the error messages still 
appear, but they do not coincide with a system crash.

Unfortunately, I was unable to get a serial console dump of any error message 
there might have been from xen, because the very workaround options that are 
needed to make the serial console work (see above) cause this bug not to 
occur.

Workaround is to remove any audio CDs before booting.
Comment 1 Robin Green 2006-05-19 17:56:45 EDT
fixed in kernel-xen0-2.6.16-1.2118_FC5

Note You need to log in before you can comment on or make changes to this bug.