Bug 190285 - rpmbuild ignore sometime remark symbol
rpmbuild ignore sometime remark symbol
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
4
All Linux
medium Severity high
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
: 190286 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-30 06:54 EDT by Frank Büttner
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-30 18:30:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Demo file for the problem (214 bytes, application/octet-stream)
2006-04-30 06:54 EDT, Frank Büttner
no flags Details

  None (edit)
Description Frank Büttner 2006-04-30 06:54:39 EDT
Description of problem:
The commend mark # is sometimes ignored

Version-Release number of selected component (if applicable):
rpm-build-4.4.1-23

How reproducible:
every time

Steps to Reproduce:
1. run rpmbuild -bb bug.spec
  
Actual results:
The variable bugtext contains dontShowThis

Expected results:
The variable contains Showthis

Additional info:
Comment 1 Frank Büttner 2006-04-30 06:54:39 EDT
Created attachment 128409 [details]
Demo file for the problem
Comment 2 Jeff Johnson 2006-04-30 18:30:28 EDT
Macros are expanded whereever they are encountered, in comments, within strings, everywhere.

Change
    #%define bugtext dontShowThis
to
    #%%define bugtext dontShowThis
to prevent the macro from being expanded and defining "dontShowThis"
Comment 3 Jeff Johnson 2006-04-30 18:32:48 EDT
*** Bug 190286 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.