Bug 190288 - rfe: yum needs "cron-apt" equivalent
rfe: yum needs "cron-apt" equivalent
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-30 09:00 EDT by Need Real Name
Modified: 2014-01-21 17:54 EST (History)
1 user (show)

See Also:
Fixed In Version: fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-04 16:16:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2006-04-30 09:00:23 EDT
It would be nice if there was a yum equivalent of cron-apt.

What would it do? It would download updates if updates were available, and
notify the admin.

yum can already check if updates are available, but it doesn't download them.
It seems useful behaviour, hence the rfe.

Why not use pup? Because I might admin the box from a shell; I don't want
everyone checking for updates.
Comment 1 Seth Vidal 2006-04-30 09:09:46 EDT
1. look into the download-only plugin
2. look at what the nightly cron job does, specifically

There's no need to add this - the functionality is already available if a user
wanted it.
Comment 2 Need Real Name 2006-04-30 12:48:05 EDT
> the functionality is already available if a user
> wanted it.

But it's useless unless a user can find it. Where is this plugin?

It's not mentioned in the online documentation:
 http://fedora.redhat.com/docs/yum/

It's not mentioned in the documentation for yum-utils
 /usr/share/doc/yum-utils-0.5/plugins/
Strangely, there seems to be not much documentation there, but lots of Python code.

$ yum list *yum*
 seems to show some plugins, but nothing called download-only.

$ locate download-only
 shows no matches

$ man -k download-only
 shows no matches

$ ls /usr/lib/yum-plugins
 shows nothing useful

$ ls /etc/cron.d/
 shows nothing yum related

$ yum provides *download-only*
 shows nothing useful
Comment 3 Seth Vidal 2006-04-30 13:22:34 EDT
1. it's in the yum plugins documentation - look there
2. I agree - it should be in the yum-utils sub-package
3. If you'd like to do this, feel free. I'd be glad to add this as an item to
yum-utils

4. it's just not a priority for me but I'd be glad to take the patch.

Comment 4 Need Real Name 2006-08-04 15:39:46 EDT
I think you've done this..

Note You need to log in before you can comment on or make changes to this bug.