Bug 190292 - RFE: Module::Build has been upgraded to 0.28
RFE: Module::Build has been upgraded to 0.28
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: perl-Module-Build (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
http://search.cpan.org/~kwilliams/Mod...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-30 11:07 EDT by Roy-Magne Mo
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.2801-1.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-14 13:26:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roy-Magne Mo 2006-04-30 11:07:56 EDT
Description of problem:
Module::Build has been upgraded to 0.28, this one does not depend on an old
version of YAML, so YAML can be upgraded too.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Roy-Magne Mo 2006-05-13 11:26:01 EDT
I see that you are pushing a new version of perl-Module-Build into mock, but I'm
wondering if increasing the epoch is the correct solution here. At the next
minor release of this package, there will be four digits in the minor version
again - and the same problems shows up. As a consequence you have to up the
epoch a lot of times going forward, and automatic dependency resolving becomes
harder. 

How about using 0.2800 as the version of the package instead of 1:0.28? This
will be greater than the existing 0.26xx package which is there today. 

But I guess this has to be applied consequently, and that probably means that
the automatic resolving of perl dependendcies in rpm should be considered
changed too. 
Comment 2 Steven Pritchard 2006-05-13 11:37:53 EDT
I really don't like having different version numbers than upstream (even if it
is just an extra 00).  Ideally, upstream should be educated in rpm's idea of
version comparison.
Comment 3 Roy-Magne Mo 2006-05-13 12:30:56 EDT
(In reply to comment #2)
> I really don't like having different version numbers than upstream (even if it
> is just an extra 00).  Ideally, upstream should be educated in rpm's idea of
> version comparison.

Can we get them to listen? Seems like there is a bug in the META.yml of the
upstream package too, since it doesn't list YAML as a requirement or a recommends. 
Comment 4 Roy-Magne Mo 2006-05-21 10:31:33 EDT
http://search.cpan.org/~kwilliams/Module-Build-0.2801/
0.2801 is out
Comment 5 Steven Pritchard 2006-05-22 17:05:57 EDT
Thanks for the heads up.

Note You need to log in before you can comment on or make changes to this bug.