Bug 190297 - INVALID MEM ALLOCATION error when trying to start X
INVALID MEM ALLOCATION error when trying to start X
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-30 14:02 EDT by dann
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-16 15:29:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (3.05 KB, text/plain)
2006-04-30 14:02 EDT, dann
no flags Details
Xorg.0.log (34.78 KB, text/plain)
2006-04-30 14:03 EDT, dann
no flags Details

  None (edit)
Description dann 2006-04-30 14:02:40 EDT
Description of problem:
When trying to use startx an "INVALID MEM ALLOCATION" error is given and
X does not start. 

system-config-display also gives an error and it creates an empty xorg.conf file.

I booted the machine using a LiveCD that I had around and copied the xorg.conf 
file that it created, and I merged that file with a xorg.conf from a working
FC5 machine. The LiveCD uses xorg-6.8.2 (in case that makes a difference), and
it uses the i810 driver.

If I use the "vesa" driver I can start X with the 640x480 resolution. 

Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-1.4.1.3-3.1

I am attaching the xorg.conf file, I will also attach the Xorg.0.log
Comment 1 dann 2006-04-30 14:02:41 EDT
Created attachment 128418 [details]
xorg.conf
Comment 2 dann 2006-04-30 14:03:44 EDT
Created attachment 128419 [details]
Xorg.0.log
Comment 3 Mike A. Harris 2006-05-23 09:43:17 EDT
Please report this issue to X.Org developers by filing a bug report in
the X.Org bugzilla located at http://bugs.freedesktop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Setting status to "NEEDINFO_REPORTER", awaiting X.Org bug URL
for tracking.
Comment 5 Mladen Sablic 2006-10-05 13:20:52 EDT
Hi, I had the same problem as described in this bug. I fixed the problem, as
suggested on freedesktop.org, by upgrading to 7.1. I took xorg RPMS from
development directory:

xorg-x11-server-Xorg-1.1.1-44.fc6.rpm
xorg-x11-drv-i810-1.6.5-9.fc6.rpm

and the rest of xorg and all dependent packages.
Comment 6 Kristian Høgsberg 2006-10-16 15:29:28 EDT
Closing bug since this is fixed in 7.1.  FC6 will be out with 7.1 and dependent
packages shortly, but I don't expect we'll do an update for FC5, unless we
rebase the entire server.

Note You need to log in before you can comment on or make changes to this bug.